summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-08-02 11:35:10 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-08-02 11:35:10 +0200
commitc279fbca22fe0cf2c6ba78c428b77f1cbef808ee (patch)
treee28819266a6a52273af2cb989e85e14dc83f4bc6 /debian/rules
parenteb3804610f695d661434cd96f3a616dd5b6d938d (diff)
run sphinx under xvfb
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7ff5b71..ea542b1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -72,7 +72,7 @@ override_dh_installman:
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
+ pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
dh_installdocs "doc/build/html" -p python-silx-doc
dh_sphinxdoc -O--buildsystem=pybuild
endif