summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-08-02 13:34:23 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-08-02 14:46:31 +0200
commitc5f7ef9ff1a5bdd60dd28ce8b53e4b7cb7891743 (patch)
treee3fdf440b9bd64c137dd885c58e5cbe70061a39d /debian
parentcf9500b725782cd5ad32517fac122a8f24a24537 (diff)
Avoid Qt warnings
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules10
2 files changed, 8 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 18ac528..5e5ad2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ silx (0.8.0+dfsg-1) unstable; urgency=medium
- Installed the QtDesigner files only for Qt5.
- Override dh_python3 to deal with qtdesigner files.
- Run sphinx with xvfb in order to have the right silx.sx documentation.
+ - Avoid QT warnings by setting XDG_RUNTIME_DIR
-- Picca Frédéric-Emmanuel <picca@debian.org> Tue, 31 Jul 2018 16:24:57 +0200
diff --git a/debian/rules b/debian/rules
index 3dab5ee..501910c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,11 @@
#!/usr/bin/make -f
+# avoir bbuild FTBFS
+export HOME=$(CURDIR)/debian/tmp-home
+export XDG_RUNTIME_DIR=$(HOME)/runtime
+export POCL_CACHE_DIR=$(HOME)/.cache/
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-export POCL_CACHE_DIR=$(CURDIR)/.cache/
export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
export SPECFILE_USE_GNU_SOURCE=1
@@ -30,7 +34,6 @@ override_dh_clean:
rm -rf doc/build/html
rm -rf build/man
rm -rf *.egg-info
- rm -rf $(POCL_CACHE_DIR)
override_dh_auto_build:
dh_auto_build
@@ -73,7 +76,8 @@ override_dh_installman:
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
- mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
+ #mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
+ mkdir -p -m 700 $(XDG_RUNTIME_DIR)
pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
dh_installdocs "doc/build/html" -p python-silx-doc
dh_sphinxdoc -O--buildsystem=pybuild