summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorStefano Rivera <stefanor@debian.org>2023-01-27 18:47:08 -0400
committerStefano Rivera <stefanor@debian.org>2023-01-27 18:47:08 -0400
commita9edc0cbc502b680205e8ed44cbf3a3d6ee5327b (patch)
tree414691b542565fa8a5799f6b9dabb4f409cc74f0 /debian
parent795a7cf80bf328537e4cdb46bc1259f1ff1629a5 (diff)
Add a patch fixing the build with Python 3.11, thanks Simon Quigley. (Closes: #1025183)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0008-python3.11-fix.patch27
-rw-r--r--debian/patches/series1
3 files changed, 35 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b55b37e..6f85af4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+silx (1.1.0+dfsg-4) unstable; urgency=medium
+
+ * Add a patch fixing the build with Python 3.11, thanks Simon Quigley.
+ (Closes: #1025183)
+
+ -- Stefano Rivera <stefanor@debian.org> Fri, 27 Jan 2023 18:46:57 -0400
+
silx (1.1.0+dfsg-3) unstable; urgency=medium
* do not run test which use lot's of memory
diff --git a/debian/patches/0008-python3.11-fix.patch b/debian/patches/0008-python3.11-fix.patch
new file mode 100644
index 0000000..79b1b9b
--- /dev/null
+++ b/debian/patches/0008-python3.11-fix.patch
@@ -0,0 +1,27 @@
+Description: Remove special-case for Python 3.11
+Author: Simon Quigley <tsimonq2@debian.org>
+Origin: vendor
+Last-Update: 2023-01-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/silx/gui/utils/testutils.py
++++ b/src/silx/gui/utils/testutils.py
+@@ -141,14 +141,10 @@ class TestCaseQt(unittest.TestCase):
+
+ def _currentTestSucceeded(self):
+ if hasattr(self, '_outcome'):
+- if hasattr(self, '_feedErrorsToResult'):
+- # For Python 3.4 -3.10
+- result = self.defaultTestResult() # these 2 methods have no side effects
+- if hasattr(self._outcome, 'errors'):
+- self._feedErrorsToResult(result, self._outcome.errors)
+- else:
+- # Python 3.11+
+- result = self._outcome.result
++ # For Python 3.4 -3.10
++ result = self.defaultTestResult() # these 2 methods have no side effects
++ if hasattr(self._outcome, 'errors'):
++ self._feedErrorsToResult(result, self._outcome.errors)
+ else:
+ # For Python < 3.4
+ result = getattr(self, '_outcomeForDoCleanups', self._resultForDoCleanups)
diff --git a/debian/patches/series b/debian/patches/series
index 0d007fc..b928d56 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@
0005-removed-hdf5plugin-from-full-dependencies.patch
0007-python3.10-fix.patch
0007-do-not-install-scipy_spatial-COPYING.txt.patch
+0008-python3.11-fix.patch