summaryrefslogtreecommitdiff
path: root/package/debian9
diff options
context:
space:
mode:
authorAlexandre Marie <alexandre.marie@synchrotron-soleil.fr>2020-07-21 14:45:14 +0200
committerAlexandre Marie <alexandre.marie@synchrotron-soleil.fr>2020-07-21 14:45:14 +0200
commit328032e2317e3ac4859196bbf12bdb71795302fe (patch)
tree8cd13462beab109e3cb53410c42335b6d1e00ee6 /package/debian9
parent33ed2a64c92b0311ae35456c016eb284e426afc2 (diff)
New upstream version 0.13.0+dfsg
Diffstat (limited to 'package/debian9')
-rw-r--r--package/debian9/control56
-rwxr-xr-xpackage/debian9/rules8
2 files changed, 5 insertions, 59 deletions
diff --git a/package/debian9/control b/package/debian9/control
index 4abe0fe..169e9b5 100644
--- a/package/debian9/control
+++ b/package/debian9/control
@@ -4,32 +4,11 @@ Uploaders: Jerome Kieffer <jerome.kieffer@esrf.fr>,
Picca Frédéric-Emmanuel <picca@debian.org>
Section: science
Priority: extra
-Build-Depends: cython,
- cython3,
+Build-Depends: cython3,
libstdc++-4.9-dev|libstdc++6,
debhelper (>=9.20150101+deb8u2),
dh-python,
- python-all-dev,
- python-numpy,
- python-fabio,
- python-h5py,
- python-pyopencl,
- python-mako,
- python-qtconsole,
- python-matplotlib,
- python-nbsphinx,
- python-dateutil,
- python-opengl,
- python-pyqt5,
- python-pyqt5.qtsvg,
- python-pyqt5.qtopengl,
- python-scipy,
- python-setuptools,
- python-sphinx,
- python-sphinxcontrib.programoutput,
- python-six,
- python-enum34,
- python-concurrent.futures,
+ graphviz,
python3-all-dev,
python3-numpy,
python3-fabio,
@@ -57,7 +36,6 @@ Standards-Version: 3.9.8
Vcs-Browser: https://anonscm.debian.org/cgit/debian-science/packages/silx.git
Vcs-Git: git://anonscm.debian.org/debian-science/packages/silx.git
Homepage: https://github.com/silx-kit/silx
-X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Package: silx
@@ -71,36 +49,6 @@ Description: Toolbox for X-Ray data analysis - Executables
.
This uses the Python 3 version of the package.
-Package: python-silx
-Architecture: any
-Section: python
-Depends: ${misc:Depends},
- ${python:Depends},
- ${shlibs:Depends},
- libstdc++6,
- python-numpy,
- python-fabio,
- python-h5py,
- python-pyopencl,
- python-mako,
- python-qtconsole,
- python-matplotlib,
- python-dateutil,
- python-opengl,
- python-pyqt5,
- python-pyqt5.qtsvg,
- python-pyqt5.qtopengl,
- python-scipy,
- python-setuptools,
- python-six,
- python-enum34,
- python-concurrent.futures,
-# Recommends:
-Suggests: python-rfoo
-Description: Toolbox for X-Ray data analysis - Python2 library
- .
- This is the Python 2 version of the package.
-
Package: python3-silx
Architecture: any
diff --git a/package/debian9/rules b/package/debian9/rules
index 160147b..655e06b 100755
--- a/package/debian9/rules
+++ b/package/debian9/rules
@@ -11,7 +11,7 @@ ALL_PYX := $(call rwildcard,silx/,*.pyx)
#NOTA: No space before *
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_clean:
dh_clean
@@ -24,10 +24,9 @@ override_dh_clean:
override_dh_auto_build:
dh_auto_build
- python setup.py build build_man build_doc
+ python3 setup.py build build_man build_doc
override_dh_install:
- dh_numpy
dh_numpy3
# move the scripts to right package
@@ -36,7 +35,6 @@ override_dh_install:
dh_install -p silx package/desktop/silx.png usr/share/icons/hicolor/48x48/apps
dh_install -p silx package/desktop/silx.svg usr/share/icons/hicolor/scalable/apps
dh_install -p silx package/desktop/silx.xml usr/share/mime/packages
- rm -rf debian/python-silx/usr/bin
rm -rf debian/python3-silx/usr/bin
dh_install
@@ -48,5 +46,5 @@ override_dh_installman:
dh_installman -p silx build/man/*.1
override_dh_installdocs:
- dh_installdocs "build/sphinx/html" -p python-silx-doc
+ dh_installdocs "build/sphinx/html" -p python-silx-doc --doc-main-package=python3-silx
dh_installdocs