summaryrefslogtreecommitdiff
path: root/package/windows
diff options
context:
space:
mode:
authorAlexandre Marie <alexandre.marie@synchrotron-soleil.fr>2020-07-21 14:45:14 +0200
committerAlexandre Marie <alexandre.marie@synchrotron-soleil.fr>2020-07-21 14:45:14 +0200
commit328032e2317e3ac4859196bbf12bdb71795302fe (patch)
tree8cd13462beab109e3cb53410c42335b6d1e00ee6 /package/windows
parent33ed2a64c92b0311ae35456c016eb284e426afc2 (diff)
New upstream version 0.13.0+dfsg
Diffstat (limited to 'package/windows')
-rw-r--r--package/windows/README.rst14
-rw-r--r--package/windows/pyinstaller-silx-view.spec7
-rw-r--r--package/windows/pyinstaller.spec7
3 files changed, 15 insertions, 13 deletions
diff --git a/package/windows/README.rst b/package/windows/README.rst
index a7f3702..97c1d54 100644
--- a/package/windows/README.rst
+++ b/package/windows/README.rst
@@ -26,12 +26,12 @@ Pre-requisites
Procedure
---------
-- Go to the `package/windows` folder in the source directory
-- Run `pyinstaller pyinstaller.spec`.
- This generates a fat binary in `package/windows/dist/silx/` for the generic launcher `silx.exe`.
-- Run `pyinstaller pyinstaller-silx-view.spec`.
- This generates a fat binary in `package/windows/dist/silx-view/` for the silx view command `silx-view.exe`.
-- Copy `silx-view.exe` and `silx-view.exe.manifest` to `package/windows/dist/silx/`.
+- Go to the ``package/windows`` folder in the source directory
+- Run ``pyinstaller pyinstaller.spec``.
+ This generates a fat binary in ``package/windows/dist/silx/`` for the generic launcher ``silx.exe``.
+- Run ``pyinstaller pyinstaller-silx-view.spec``.
+ This generates a fat binary in ``package/windows/dist/silx-view/`` for the silx view command ``silx-view.exe``.
+- Copy ``silx-view.exe`` and ``silx-view.exe.manifest`` to ``package/windows/dist/silx/``.
This is a hack until PyInstaller supports multiple executables (see https://github.com/pyinstaller/pyinstaller/issues/1527).
-- Zip `package\windows\dist\silx` to make the application available as a single zip file.
+- Zip ``package\windows\dist\silx`` to make the application available as a single zip file.
diff --git a/package/windows/pyinstaller-silx-view.spec b/package/windows/pyinstaller-silx-view.spec
index 6f36128..cf01fd1 100644
--- a/package/windows/pyinstaller-silx-view.spec
+++ b/package/windows/pyinstaller-silx-view.spec
@@ -1,6 +1,6 @@
# -*- mode: python -*-
import os.path
-from PyInstaller.utils.hooks import collect_data_files
+from PyInstaller.utils.hooks import collect_data_files, collect_submodules
datas = []
@@ -8,9 +8,10 @@ PROJECT_PATH = os.path.abspath(os.path.join(SPECPATH, "..", ".."))
datas.append((os.path.join(PROJECT_PATH, "README.rst"), "."))
datas.append((os.path.join(PROJECT_PATH, "LICENSE"), "."))
datas.append((os.path.join(PROJECT_PATH, "copyright"), "."))
+datas += collect_data_files("silx.resources")
-datas += collect_data_files("silx.resources")
+hiddenimports = collect_submodules('fabio')
block_cipher = None
@@ -20,7 +21,7 @@ a = Analysis(['bootstrap-silx-view.py'],
pathex=[],
binaries=[],
datas=datas,
- hiddenimports=[],
+ hiddenimports=hiddenimports,
hookspath=[],
runtime_hooks=[],
excludes=[],
diff --git a/package/windows/pyinstaller.spec b/package/windows/pyinstaller.spec
index 74d6a0f..548e41a 100644
--- a/package/windows/pyinstaller.spec
+++ b/package/windows/pyinstaller.spec
@@ -1,6 +1,6 @@
# -*- mode: python -*-
import os.path
-from PyInstaller.utils.hooks import collect_data_files
+from PyInstaller.utils.hooks import collect_data_files, collect_submodules
datas = []
@@ -8,9 +8,10 @@ PROJECT_PATH = os.path.abspath(os.path.join(SPECPATH, "..", ".."))
datas.append((os.path.join(PROJECT_PATH, "README.rst"), "."))
datas.append((os.path.join(PROJECT_PATH, "LICENSE"), "."))
datas.append((os.path.join(PROJECT_PATH, "copyright"), "."))
+datas += collect_data_files("silx.resources")
-datas += collect_data_files("silx.resources")
+hiddenimports = collect_submodules('fabio')
block_cipher = None
@@ -20,7 +21,7 @@ a = Analysis(['bootstrap.py'],
pathex=[],
binaries=[],
datas=datas,
- hiddenimports=[],
+ hiddenimports=hiddenimports,
hookspath=[],
runtime_hooks=[],
excludes=[],