summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 10:20:27 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 10:20:27 +0100
commit270d5ddc31c26b62379e3caa9044dd75ccc71847 (patch)
tree55c5bfc851dfce7172d335cd2405b214323e3caf /package
parente19c96eff0c310c06c4f268c8b80cb33bd08996f (diff)
New upstream version 0.7.0+dfsg
Diffstat (limited to 'package')
-rw-r--r--package/debian8/control9
-rwxr-xr-xpackage/debian8/rules1
-rw-r--r--package/debian9/control5
-rwxr-xr-xpackage/debian9/rules1
-rw-r--r--package/desktop/org.silx.SilxView.desktop10
-rw-r--r--package/desktop/silx.xml60
6 files changed, 74 insertions, 12 deletions
diff --git a/package/debian8/control b/package/debian8/control
index f10cd97..212266a 100644
--- a/package/debian8/control
+++ b/package/debian8/control
@@ -25,7 +25,6 @@ Build-Depends: cython,
python-pyopencl-dbg,
python-mako,
ipython,
- ipython-qtconsole,
python-matplotlib,
python-matplotlib-dbg,
python-opengl,
@@ -38,6 +37,7 @@ Build-Depends: cython,
python-sphinx,
python-sphinxcontrib.programoutput,
python-enum34,
+ python-concurrent.futures,
python3-all-dev,
python3-all-dbg,
python3-numpy,
@@ -50,7 +50,6 @@ Build-Depends: cython,
python3-pyopencl-dbg,
python3-mako,
ipython3,
- ipython3-qtconsole,
python3-matplotlib,
python3-matplotlib-dbg,
python3-opengl,
@@ -94,7 +93,6 @@ Depends: ${misc:Depends},
python-pyopencl,
python-mako,
ipython,
- ipython-qtconsole,
python-matplotlib,
python-opengl,
python-pyqt5,
@@ -102,6 +100,7 @@ Depends: ${misc:Depends},
python-scipy,
python-six,
python-enum34,
+ python-concurrent.futures,
# Recommends:
Suggests: python-rfoo
Description: Toolbox for X-Ray data analysis - Python2 library
@@ -123,7 +122,6 @@ Depends: ${misc:Depends},
python-pyopencl-dbg,
python-mako,
ipython,
- ipython-qtconsole,
python-matplotlib-dbg,
python-opengl,
python-pyqt5-dbg,
@@ -131,6 +129,7 @@ Depends: ${misc:Depends},
python-scipy-dbg,
python-six,
python-enum34,
+ python-concurrent.futures,
Description: Toolbox for X-Ray data analysis - python2 debug
.
This package contains the extension built for the Python 2 debug
@@ -149,7 +148,6 @@ Depends: ${misc:Depends},
python3-pyopencl,
python3-mako,
ipython3,
- ipython3-qtconsole,
python3-matplotlib,
python3-opengl,
python3-pyqt5,
@@ -177,7 +175,6 @@ Depends: ${misc:Depends},
python3-pyopencl-dbg,
python3-mako,
ipython3,
- ipython3-qtconsole,
python3-matplotlib-dbg,
python3-opengl,
python3-pyqt5-dbg,
diff --git a/package/debian8/rules b/package/debian8/rules
index d6cd69b..f72ed66 100755
--- a/package/debian8/rules
+++ b/package/debian8/rules
@@ -35,6 +35,7 @@ override_dh_install:
dh_install -p silx package/desktop/*.desktop usr/share/applications
dh_install -p silx package/desktop/silx.png usr/share/icons/hicolor/48x48/apps
dh_install -p silx package/desktop/silx.svg usr/share/icons/hicolor/scalable/apps
+ dh_install -p silx package/desktop/silx.xml usr/share/mime/packages
rm -rf debian/python-silx/usr/bin
rm -rf debian/python3-silx/usr/bin
diff --git a/package/debian9/control b/package/debian9/control
index 193b844..4c244f1 100644
--- a/package/debian9/control
+++ b/package/debian9/control
@@ -6,8 +6,7 @@ Section: science
Priority: extra
Build-Depends: cython,
cython3,
- libstdc++-4.9-dev,
- libstdc++6,
+ libstdc++-4.9-dev|libstdc++6,
debhelper (>=9.20150101+deb8u2),
dh-python,
python-all-dev,
@@ -26,6 +25,7 @@ Build-Depends: cython,
python-sphinx,
python-sphinxcontrib.programoutput,
python-enum34,
+ python-concurrent.futures,
python3-all-dev,
python3-numpy,
python3-fabio,
@@ -82,6 +82,7 @@ Depends: ${misc:Depends},
python-scipy,
python-six,
python-enum34,
+ python-concurrent.futures,
# Recommends:
Suggests: python-rfoo
Description: Toolbox for X-Ray data analysis - Python2 library
diff --git a/package/debian9/rules b/package/debian9/rules
index b348c51..160147b 100755
--- a/package/debian9/rules
+++ b/package/debian9/rules
@@ -35,6 +35,7 @@ override_dh_install:
dh_install -p silx package/desktop/*.desktop usr/share/applications
dh_install -p silx package/desktop/silx.png usr/share/icons/hicolor/48x48/apps
dh_install -p silx package/desktop/silx.svg usr/share/icons/hicolor/scalable/apps
+ dh_install -p silx package/desktop/silx.xml usr/share/mime/packages
rm -rf debian/python-silx/usr/bin
rm -rf debian/python3-silx/usr/bin
diff --git a/package/desktop/org.silx.SilxView.desktop b/package/desktop/org.silx.SilxView.desktop
index 577c0c8..02d615e 100644
--- a/package/desktop/org.silx.SilxView.desktop
+++ b/package/desktop/org.silx.SilxView.desktop
@@ -1,9 +1,11 @@
[Desktop Entry]
+Version=1.0
Type=Application
-Encoding=UTF-8
-Name=silx Data Viewer
+Name=silx data viewer
Comment=HDF5 EDF SPEC Data Viewer
Exec=silx view %F
-Terminal=false
+TryExec=silx
Icon=silx
-Categories=Education;Science;DataVisualization;Qt
+Terminal=false
+Categories=Education;Science;DataVisualization;Qt;
+MimeType=image/tiff;application/x-hdf;application/x-silx-hdf5;application/x-silx-nexus;application/x-silx-specfile;image/x-silx-marccd;image/x-silx-cbf;image/x-silx-edf;image/x-silx-numpy;
diff --git a/package/desktop/silx.xml b/package/desktop/silx.xml
new file mode 100644
index 0000000..e98d6a3
--- /dev/null
+++ b/package/desktop/silx.xml
@@ -0,0 +1,60 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+
+ <!-- HDF5 -->
+
+ <mime-type type="application/x-silx-hdf5">
+ <comment>Hierarchical Data Format</comment>
+ <sub-class-of type="application/x-hdf"/>
+ <glob pattern="*.h5"/>
+ <glob pattern="*.hdf"/>
+ <glob pattern="*.hdf5"/>
+ </mime-type>
+
+ <mime-type type="application/x-silx-nexus">
+ <comment>NeXus file</comment>
+ <sub-class-of type="application/x-silx-hdf5"/>
+ <glob pattern="*.nx"/>
+ <glob pattern="*.nxs"/>
+ <glob pattern="*.h5"/>
+ <glob pattern="*.hdf"/>
+ </mime-type>
+
+ <!-- Spec formats -->
+
+ <mime-type type="application/x-silx-specfile">
+ <comment>Spec file</comment>
+ <glob pattern="*.spec"/>
+ <glob pattern="*.mca"/>
+ <glob pattern="*.dat"/>
+ </mime-type>
+
+ <!-- Image formats -->
+
+ <mime-type type="image/x-silx-marccd">
+ <comment>MarCCD image file</comment>
+ <sub-class-of type="image/tiff"/>
+ <glob pattern="*.mccd"/>
+ </mime-type>
+
+ <mime-type type="image/x-silx-cbf">
+ <comment>CBF image file</comment>
+ <acronym>CBF</acronym>
+ <expanded-acronym>Crystallographic Information File</expanded-acronym>
+ <glob pattern="*.cbf"/>
+ </mime-type>
+
+ <mime-type type="image/x-silx-edf">
+ <comment>EDF image file</comment>
+ <acronym>EDF</acronym>
+ <expanded-acronym>ESRF data format</expanded-acronym>
+ <glob pattern="*.edf"/>
+ </mime-type>
+
+ <mime-type type="image/x-silx-numpy">
+ <comment>Numpy data file</comment>
+ <glob pattern="*.npz"/>
+ <glob pattern="*.npy"/>
+ </mime-type>
+
+</mime-info> \ No newline at end of file