summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2022-11-03 10:02:44 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2022-11-03 10:02:44 +0100
commit1c380bfeff1e13a9f7d506460336659502ca052d (patch)
tree48081d47748d4563eeaa76662287eb19638c8591 /package
parent4e774db12d5ebe7a20eded6dd434a289e27999e5 (diff)
New upstream version 1.1.0+dfsg
Diffstat (limited to 'package')
-rwxr-xr-xpackage/debian10/rules1
-rwxr-xr-xpackage/debian11/rules1
-rw-r--r--package/windows/bootstrap-silx-view.py1
-rw-r--r--package/windows/bootstrap.py1
-rw-r--r--package/windows/create-installer.iss.template2
-rw-r--r--package/windows/pyinstaller.spec29
6 files changed, 32 insertions, 3 deletions
diff --git a/package/debian10/rules b/package/debian10/rules
index e56f801..3a4310d 100755
--- a/package/debian10/rules
+++ b/package/debian10/rules
@@ -10,6 +10,7 @@ export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
export SPECFILE_USE_GNU_SOURCE=1
export SILX_FULL_INSTALL_REQUIRES=1
+export SILX_INSTALL_REQUIRES_STRIP=hdf5plugin
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
diff --git a/package/debian11/rules b/package/debian11/rules
index d086f63..57ff649 100755
--- a/package/debian11/rules
+++ b/package/debian11/rules
@@ -10,6 +10,7 @@ export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
export SPECFILE_USE_GNU_SOURCE=1
export SILX_FULL_INSTALL_REQUIRES=1
+export SILX_INSTALL_REQUIRES_STRIP=hdf5plugin
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
diff --git a/package/windows/bootstrap-silx-view.py b/package/windows/bootstrap-silx-view.py
index f8da02d..9d17483 100644
--- a/package/windows/bootstrap-silx-view.py
+++ b/package/windows/bootstrap-silx-view.py
@@ -1,4 +1,3 @@
-# coding: utf-8
import logging
diff --git a/package/windows/bootstrap.py b/package/windows/bootstrap.py
index 3c6e887..06800ad 100644
--- a/package/windows/bootstrap.py
+++ b/package/windows/bootstrap.py
@@ -1,4 +1,3 @@
-# coding: utf-8
import logging
diff --git a/package/windows/create-installer.iss.template b/package/windows/create-installer.iss.template
index ffb6af4..3e913b9 100644
--- a/package/windows/create-installer.iss.template
+++ b/package/windows/create-installer.iss.template
@@ -9,7 +9,7 @@ AppSupportURL=https://github.com/silx-kit/silx
AppUpdatesURL=https://github.com/silx-kit/silx/releases
DefaultDirName={autopf}\silx
DefaultGroupName=silx
-LicenseFile=..\..\LICENSE
+LicenseFile=LICENSE
OutputDir=artifacts
OutputBaseFilename=silx-#Version-x64
Compression=lzma
diff --git a/package/windows/pyinstaller.spec b/package/windows/pyinstaller.spec
index 59b66c1..a0066cf 100644
--- a/package/windows/pyinstaller.spec
+++ b/package/windows/pyinstaller.spec
@@ -1,8 +1,12 @@
# -*- mode: python -*-
+import importlib.metadata
import os.path
from pathlib import Path
import shutil
import subprocess
+import sys
+
+import pkg_resources
from PyInstaller.utils.hooks import collect_data_files, collect_submodules
@@ -127,6 +131,31 @@ def move_silx_view_exe():
move_silx_view_exe()
+# Generate license file from current Python env
+def create_license_file(filename: str):
+ import PyQt5.QtCore
+
+ with open(filename, 'w') as f:
+ f.write(f"""
+This is free software.
+
+This distribution of silx is provided under the
+GNU General Public License v3 (https://www.gnu.org/licenses/gpl-3.0.en.html) since it includes PyQt5.
+
+It includes mainy software packages with different licenses:
+
+- Python ({sys.version}): PSF license, https://www.python.org/
+- Qt ({PyQt5.QtCore.qVersion()}): GNU Lesser General Public License v3, https://www.qt.io/
+""")
+
+ for dist in sorted(pkg_resources.working_set, key=lambda d: d.key):
+ license = importlib.metadata.metadata(dist.key).get('License')
+ homepage = importlib.metadata.metadata(dist.key).get('Home-page')
+ info = ", ".join(info for info in (license, homepage) if info)
+ f.write(f"- {dist.project_name} ({importlib.metadata.version(dist.key)}): {info}\n")
+
+create_license_file('LICENSE')
+
# Run innosetup
def innosetup():
from silx import version