summaryrefslogtreecommitdiff
path: root/patches
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2017-11-25 17:02:19 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2017-11-25 17:02:19 +0100
commitf419d864bfd0f271bb0c3c2f5485f81fda869906 (patch)
tree057bfc1368eda812394ecb94a250380ffc1a86ba /patches
Import silx_0.6.1+dfsg-1.debian.tar.xz
[dgit import tarball silx 0.6.1+dfsg-1 silx_0.6.1+dfsg-1.debian.tar.xz]
Diffstat (limited to 'patches')
-rw-r--r--patches/0002-use-the-system-mathjax-privacy-breach.patch25
-rw-r--r--patches/0003-fix-unit-test.patch29
-rw-r--r--patches/0006-prefer-pyqt5-over-pyside.patch52
-rw-r--r--patches/0007-add-install_requires-dependencies.patch38
-rw-r--r--patches/series4
5 files changed, 148 insertions, 0 deletions
diff --git a/patches/0002-use-the-system-mathjax-privacy-breach.patch b/patches/0002-use-the-system-mathjax-privacy-breach.patch
new file mode 100644
index 0000000..cb6fb00
--- /dev/null
+++ b/patches/0002-use-the-system-mathjax-privacy-breach.patch
@@ -0,0 +1,25 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 10 Aug 2017 10:19:39 +0200
+Subject: use the system mathjax (privacy breach)
+
+---
+ doc/source/conf.py | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/doc/source/conf.py b/doc/source/conf.py
+index e724d3c..d01cd39 100644
+--- a/doc/source/conf.py
++++ b/doc/source/conf.py
+@@ -133,6 +133,11 @@ pygments_style = 'sphinx'
+ # A list of ignored prefixes for module index sorting.
+ # modindex_common_prefix = []
+
++# -- Option for MathJax extension ----------------------------------------------
++
++# Override required in order to use Debian's system mathjax
++mathjax_path = 'file:///usr/share/javascript/mathjax/MathJax.js?config=TeX-AMS-MML_HTMLorMML'
++
+
+ # -- Options for HTML output ---------------------------------------------------
+
diff --git a/patches/0003-fix-unit-test.patch b/patches/0003-fix-unit-test.patch
new file mode 100644
index 0000000..e441748
--- /dev/null
+++ b/patches/0003-fix-unit-test.patch
@@ -0,0 +1,29 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Fri, 11 Aug 2017 10:15:26 +0200
+Subject: fix unit test
+
+---
+ silx/opencl/common.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/silx/opencl/common.py b/silx/opencl/common.py
+index ebf50c7..5661530 100644
+--- a/silx/opencl/common.py
++++ b/silx/opencl/common.py
+@@ -61,7 +61,14 @@ else:
+ pyopencl = None
+ else:
+ import pyopencl.array as array
+- mf = pyopencl.mem_flags
++
++if pyopencl is None:
++ class mf(object):
++ WRITE_ONLY = 1
++ READ_ONLY = 1
++ READ_WRITE = 1
++else:
++ mf = pyopencl.mem_flags
+
+ if pyopencl is None:
+ # Define default mem flags
diff --git a/patches/0006-prefer-pyqt5-over-pyside.patch b/patches/0006-prefer-pyqt5-over-pyside.patch
new file mode 100644
index 0000000..253751b
--- /dev/null
+++ b/patches/0006-prefer-pyqt5-over-pyside.patch
@@ -0,0 +1,52 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Mon, 14 Aug 2017 14:58:02 +0200
+Subject: prefer pyqt5 over pyside
+
+---
+ silx/gui/qt/_qt.py | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/silx/gui/qt/_qt.py b/silx/gui/qt/_qt.py
+index 0962c21..67f3e46 100644
+--- a/silx/gui/qt/_qt.py
++++ b/silx/gui/qt/_qt.py
+@@ -64,12 +64,12 @@ HAS_OPENGL = False
+ """True if Qt provides support for OpenGL (QtOpenGL)."""
+
+ # First check for an already loaded wrapper
+-if 'PySide.QtCore' in sys.modules:
+- BINDING = 'PySide'
+-
+-elif 'PyQt5.QtCore' in sys.modules:
++if 'PyQt5.QtCore' in sys.modules:
+ BINDING = 'PyQt5'
+
++elif 'PySide.QtCore' in sys.modules:
++ BINDING = 'PySide'
++
+ elif 'PyQt4.QtCore' in sys.modules:
+ BINDING = 'PyQt4'
+
+@@ -78,17 +78,17 @@ else: # Then try Qt bindings
+ import PyQt4 # noqa
+ except ImportError:
+ try:
+- import PySide # noqa
++ import PyQt5 # noqa
+ except ImportError:
+ try:
+- import PyQt5 # noqa
++ import PySide # noqa
+ except ImportError:
+ raise ImportError(
+ 'No Qt wrapper found. Install PyQt4, PyQt5 or PySide.')
+ else:
+- BINDING = 'PyQt5'
++ BINDING = 'PySide'
+ else:
+- BINDING = 'PySide'
++ BINDING = 'PyQt5'
+ else:
+ BINDING = 'PyQt4'
+
diff --git a/patches/0007-add-install_requires-dependencies.patch b/patches/0007-add-install_requires-dependencies.patch
new file mode 100644
index 0000000..8d5759b
--- /dev/null
+++ b/patches/0007-add-install_requires-dependencies.patch
@@ -0,0 +1,38 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 17 Aug 2017 09:30:39 +0200
+Subject: add install_requires dependencies
+
+---
+ setup.py | 18 +++++++++++++++++-
+ 1 file changed, 17 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index bede4df..c41df00 100644
+--- a/setup.py
++++ b/setup.py
+@@ -701,7 +701,23 @@ def get_project_configuration(dry_run):
+ # for most of the computation
+ "numpy",
+ # for the script launcher
+- "setuptools"]
++ "setuptools",
++ # Debian added
++ "ipython",
++ "qtconsole",
++ 'enum34;python_version<"3.4"',
++ "fabio",
++ "h5py",
++ "lxml",
++ "mako",
++ "matplotlib",
++ "PyOpenGL",
++ "pil",
++ "pyopencl",
++ "PyQt5",
++ "scipy",
++ "six"
++ ]
+
+ setup_requires = ["setuptools", "numpy"]
+
diff --git a/patches/series b/patches/series
new file mode 100644
index 0000000..b1878a6
--- /dev/null
+++ b/patches/series
@@ -0,0 +1,4 @@
+0002-use-the-system-mathjax-privacy-breach.patch
+0003-fix-unit-test.patch
+0006-prefer-pyqt5-over-pyside.patch
+0007-add-install_requires-dependencies.patch