summaryrefslogtreecommitdiff
path: root/requirements.txt
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2024-02-05 16:30:07 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2024-02-05 16:30:07 +0100
commit04095a69f18767d222b16fae5b40f2b712cd6f7e (patch)
treed20abd3ee2f237319443e9dfd7500ad55d29a33d /requirements.txt
parent3427caf0e96690e56aac6231a91df8f0f7a64fc2 (diff)
New upstream version 2.0.0+dfsg
Diffstat (limited to 'requirements.txt')
-rw-r--r--requirements.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/requirements.txt b/requirements.txt
index 15e3ec5..f5074bd 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -3,12 +3,16 @@
--trusted-host www.silx.org
--find-links http://www.silx.org/pub/wheelhouse/
---only-binary numpy,h5py,scipy,PySide2,PyQt5,PySide6,PyQt6
+--only-binary numpy,h5py,scipy,PyQt5,PySide6,PyQt6
-# Required dependencies (from setup.py setup_requires and install_requires)
+# Required dependencies
+# From pyproject.toml
+wheel
+setuptools
numpy >= 1.12
-setuptools < 60.0.0
Cython >= 0.21.1
+# From setup.py install_requires
+packaging
h5py
fabio >= 0.9
@@ -16,7 +20,7 @@ fabio >= 0.9
pyopencl; platform_machine in "i386, x86_64, AMD64" # For silx.opencl
Mako # For pyopencl reduction
qtconsole # For silx.gui.console
-matplotlib >= 1.2.0 # For silx.gui.plot
+matplotlib >= 3.1.0 # For silx.gui.plot
PyOpenGL # For silx.gui.plot3d
python-dateutil # For silx.gui.plot
scipy # For silx.math.fit demo, silx.image.sift demo, silx.image.sift.test