summaryrefslogtreecommitdiff
path: root/requirements.txt
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-05-28 08:16:16 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2019-05-28 08:16:16 +0200
commita763e5d1b3921b3194f3d4e94ab9de3fbe08bbdd (patch)
tree45d462ed36a5522e9f3b9fde6c4ec4918c2ae8e3 /requirements.txt
parentcebdc9244c019224846cb8d2668080fe386a6adc (diff)
New upstream version 0.10.1+dfsg
Diffstat (limited to 'requirements.txt')
-rw-r--r--requirements.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/requirements.txt b/requirements.txt
index 90dc020..2f75c73 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -5,17 +5,24 @@
--find-links http://www.silx.org/pub/wheelhouse/
--only-binary numpy,h5py,scipy,PyQt4,PyQt5
+# Required dependencies (from setup.py install_requires)
numpy >= 1.8
-fabio >= 0.7
+setuptools
h5py
-scipy # For silx.math.fit demo, silx.image.sift demo, silx.image.sift.test
-pyopencl; platform_machine in "i386, x86_64" # For silx.opencl
+fabio >= 0.7
+six
+enum34; python_version == '2.7'
+futures; python_version == '2.7'
+
+# Extra dependencies (from setup.py extra_requires 'full' target)
+pyopencl; platform_machine in "i386, x86_64, AMD64" # For silx.opencl
Mako # For pyopencl reduction
qtconsole # For silx.gui.console
matplotlib >= 1.2.0 # For silx.gui.plot
PyOpenGL # For silx.gui.plot3d
-Pillow # For silx.opencl.image.test
python-dateutil # For silx.gui.plot
+scipy # For silx.math.fit demo, silx.image.sift demo, silx.image.sift.test
+Pillow # For silx.opencl.image.test
# PyQt5, PySide2 or PyQt4 # For silx.gui
# Try to install a Qt binding from a wheel