summaryrefslogtreecommitdiff
path: root/silx.egg-info
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 10:20:27 +0100
committerPicca Frédéric-Emmanuel <picca@debian.org>2018-03-04 10:20:27 +0100
commit270d5ddc31c26b62379e3caa9044dd75ccc71847 (patch)
tree55c5bfc851dfce7172d335cd2405b214323e3caf /silx.egg-info
parente19c96eff0c310c06c4f268c8b80cb33bd08996f (diff)
New upstream version 0.7.0+dfsg
Diffstat (limited to 'silx.egg-info')
-rw-r--r--silx.egg-info/PKG-INFO139
-rw-r--r--silx.egg-info/SOURCES.txt149
2 files changed, 188 insertions, 100 deletions
diff --git a/silx.egg-info/PKG-INFO b/silx.egg-info/PKG-INFO
index ed985dc..907a50f 100644
--- a/silx.egg-info/PKG-INFO
+++ b/silx.egg-info/PKG-INFO
@@ -1,7 +1,7 @@
Metadata-Version: 1.1
Name: silx
-Version: 0.6.1
-Summary: Software library for X-Ray data analysis
+Version: 0.7.0
+Summary: Software library for X-ray data analysis
Home-page: http://www.silx.org/
Author: data analysis unit
Author-email: silx@esrf.fr
@@ -10,127 +10,77 @@ Description:
silx toolkit
============
- The silx project aims at providing a collection of Python packages to support the
+ The purpose of the *silx* project is to provide a collection of Python packages to support the
development of data assessment, reduction and analysis applications at synchrotron
radiation facilities.
It aims at providing reading/writing different file formats, data reduction routines
- and a set of Qt widgets to browse and visualize data.
+ and a set of Qt widgets to browse and visualise data.
- The current version provides:
+ The current version features:
- * reading `HDF5 <https://www.hdfgroup.org/HDF5/>`_ file format (with support of
- `SPEC <https://certif.com/spec.html>`_ file format and
+ * Support of `HDF5 <https://www.hdfgroup.org/HDF5/>`_,
+ `SPEC <https://certif.com/spec.html>`_ and
`FabIO <http://www.silx.org/doc/fabio/dev/getting_started.html#list-of-file-formats-that-fabio-can-read-and-write>`_
- images)
- * histogramming
- * fitting
- * 1D and 2D visualization widgets using multiple backends (matplotlib or OpenGL)
- * an OpenGL-based widget to display 3D scalar field with isosurface and cutting plane
- * an image plot widget with a set of associated tools
- * a unified browser for HDF5, SPEC and image file formats supporting inspection and
- visualization of n-dimensional datasets.
- * a unified viewer (*silx view filename*) for HDF5, SPEC and image file formats
- * a unified converter to HDF5 format (*silx convert filename*)
- * median filters on images (C and OpenCL implementations)
- * image alignement (sift - OpenCL implementation)
- * filtered backprojection and forward projection for tomography
+ images file formats.
+ * OpenCL-based data processing: image alignment (SIFT),
+ image processing (median filter, histogram),
+ filtered backprojection for tomography
+ * Data reduction: histogramming, fitting, median filter
+ * A set of Qt widgets, including:
+
+ * 1D and 2D visualization widgets with a set of associated tools using multiple backends (matplotlib or OpenGL)
+ * OpenGL-based widgets to visualize data in 3D (scalar field with isosurface and cut plane, scatter plot)
+ * a unified browser for HDF5, SPEC and image file formats supporting inspection and
+ visualization of n-dimensional datasets.
+
+ * a set of applications:
+
+ * a unified viewer (*silx view filename*) for HDF5, SPEC and image file formats
+ * a unified converter to HDF5 format (*silx convert filename*)
Installation
------------
- To install silx, run::
+ To install silx, run:
+
+ .. code-block:: bash
pip install silx
- Or with Anaconda on Linux and MacOS::
+ Or using Anaconda on Linux and MacOS:
+
+ .. code-block:: bash
conda install silx -c conda-forge
- To install silx locally, run::
-
- pip install silx --user
-
- Unofficial packages for different distributions are available :
+ Unofficial packages for different distributions are available:
- Unofficial Debian8 packages are available at http://www.silx.org/pub/debian/
- - CentOS 7 rpm packages are provided by Max IV at the following url: http://pubrepo.maxiv.lu.se/rpm/el7/x86_64/
+ - CentOS 7 rpm packages are provided by Max IV at: http://pubrepo.maxiv.lu.se/rpm/el7/x86_64/
- Fedora 23 rpm packages are provided by Max IV at http://pubrepo.maxiv.lu.se/rpm/fc23/x86_64/
- Arch Linux (AUR) packages are also available: https://aur.archlinux.org/packages/python-silx
- Beside this, we provide a certain number of wheels (pre-compiled binary packages) to be installed
- onto a pre-existing Python installation:
-
- - On Windows, binary wheels are available for Python 2.7, 3.5 and 3.6.
- - On MacOS, binary wheels are available for Python 2.7, 3.5 and 3.6.
- - On Linux, manylinux1 binary wheels are available for Python 2.7, 3.4, 3.5 and 3.6.
-
- Those builds are made from "up-date" systems at the time of the release, i.e. they use
- the latest stable version of numpy (and cython).
- Hence your system should use a fairly recent version of numpy to be compatible with silx.
- This can be achieved simply by::
-
- pip install numpy --upgrade
-
-
- The latest development version can be obtained from the git repository::
-
- git clone https://github.com/silx-kit/silx.git
- cd silx
- pip install . [--user]
-
- Dependencies
- ------------
-
- * `Python <https://www.python.org/>`_ 2.7, 3.4 or above.
- * `numpy <http://www.numpy.org>`_
-
- The GUI widgets of the silx package depend on the following extra packages:
-
- * A Qt binding: `PyQt5, PyQt4 <https://riverbankcomputing.com/software/pyqt/intro>`_ (using API version 2) or `PySide <https://pypi.python.org/pypi/PySide/>`_
- * `matplotlib <http://matplotlib.org/>`_ for the silx.gui.plot package
- * `PyOpenGL <http://pyopengl.sourceforge.net/>`_ for the silx.gui.plot3d package
-
- Most modules and functions dealing with `HDF5 <https://www.hdfgroup.org/HDF5/>`_ input/output depend on:
-
- * `h5py <http://www.h5py.org/>`_
-
- Parallel algorithms depend on:
-
- * `PyOpenCL <https://documen.tician.de/pyopencl/>`_
-
- The console widgets depend on:
-
- * `ipython <https://ipython.org/>`_
- * `qtconsole <https://pypi.python.org/pypi/qtconsole>`_
-
-
- Supported platforms: Linux, Windows, Mac OS X.
+ `Detailed installation instructions <http://www.silx.org/doc/silx/dev/install.html>`_
+ are available in the documentation.
Documentation
-------------
- Documentation of latest release is available at http://www.silx.org/doc/silx/latest/
-
- Documentation of previous releases and nightly build is available at http://www.silx.org/doc/silx/
-
- To build the documentation from the source (requires `Sphinx <http://www.sphinx-doc.org>`_), run::
-
- python setup.py build build_doc
+ The documentation of `latest release <http://www.silx.org/doc/silx/latest/>`_ and
+ the documentation of `the nightly build <http://www.silx.org/doc/silx/dev>`_ are
+ available at http://www.silx.org/doc/silx/
Testing
-------
+ *silx* features a comprehensive test-suite used in continuous integration for
+ all major operating systems:
+
- Travis CI status: |Travis Status|
- Appveyor CI status: |Appveyor Status|
- To run the tests from the python interpreter, run:
-
- >>> import silx.test
- >>> silx.test.run_tests()
-
- To run the tests, from the source directory, run::
-
- python run_tests.py
+ Please refer to the `documentation on testing <http://www.silx.org/doc/silx/dev/install.html#testing>`_
+ for details.
Examples
--------
@@ -142,13 +92,14 @@ Description:
License
-------
- The source code of silx is licensed under the MIT license.
- See the `LICENSE <https://github.com/silx-kit/silx/blob/master/LICENSE>`_ and `copyright <https://github.com/silx-kit/silx/blob/master/copyright>`_ files for details.
+ The source code of *silx* is licensed under the MIT license.
+ See the `LICENSE <https://github.com/silx-kit/silx/blob/master/LICENSE>`_ and
+ `copyright <https://github.com/silx-kit/silx/blob/master/copyright>`_ files for details.
Citation
--------
- silx releases can be cited by their DOI on Zenodo: |zenodo DOI|
+ *silx* releases can be cited via their DOI on Zenodo: |zenodo DOI|
.. |Travis Status| image:: https://travis-ci.org/silx-kit/silx.svg?branch=master
:target: https://travis-ci.org/silx-kit/silx
diff --git a/silx.egg-info/SOURCES.txt b/silx.egg-info/SOURCES.txt
index 5de21ae..734f4b2 100644
--- a/silx.egg-info/SOURCES.txt
+++ b/silx.egg-info/SOURCES.txt
@@ -19,11 +19,11 @@ doc/source/overview.rst
doc/source/tutorials.rst
doc/source/virtualenv.rst
doc/source/Tutorials/array_widget.rst
+doc/source/Tutorials/convert.rst
doc/source/Tutorials/fit.rst
doc/source/Tutorials/fitconfig.rst
doc/source/Tutorials/io.rst
doc/source/Tutorials/specfile_to_hdf5.rst
-doc/source/Tutorials/Sift/sift.rst
doc/source/Tutorials/img/arraywidget3D_0.png
doc/source/Tutorials/img/arraywidget3D_1.png
doc/source/Tutorials/img/arraywidget5D_0.png
@@ -39,6 +39,12 @@ doc/source/Tutorials/img/fitwidget5.png
doc/source/Tutorials/img/silx_view_edf.png
doc/source/Tutorials/img/stripbg_plot1.png
doc/source/Tutorials/img/stripbg_plot2.png
+doc/source/applications/convert.rst
+doc/source/applications/index.rst
+doc/source/applications/view.rst
+doc/source/applications/img/silx-view-hdf5.png
+doc/source/applications/img/silx-view-image.png
+doc/source/applications/img/silx-view-table.png
doc/source/description/index.rst
doc/source/description/sift.rst
doc/source/description/img/sift_bench_cpu0.png
@@ -58,6 +64,7 @@ doc/source/img/silx_large.png
doc/source/img/silx_small.png
doc/source/modules/index.rst
doc/source/modules/resources.rst
+doc/source/modules/sx.rst
doc/source/modules/gui/console.rst
doc/source/modules/gui/designer.rst
doc/source/modules/gui/gallery.rst
@@ -75,6 +82,13 @@ doc/source/modules/gui/data/img/ArrayTableWidget.png
doc/source/modules/gui/data/img/DataViewer.png
doc/source/modules/gui/data/img/DataViewerFrame.png
doc/source/modules/gui/data/img/NumpyAxesSelector.png
+doc/source/modules/gui/dialog/abstractdatafiledialog.rst
+doc/source/modules/gui/dialog/datafiledialog.rst
+doc/source/modules/gui/dialog/imagefiledialog.rst
+doc/source/modules/gui/dialog/index.rst
+doc/source/modules/gui/dialog/img/datafiledialog.png
+doc/source/modules/gui/dialog/img/imagefiledialog_edf.png
+doc/source/modules/gui/dialog/img/imagefiledialog_h5.png
doc/source/modules/gui/fit/backgroundwidget.rst
doc/source/modules/gui/fit/fitwidget.rst
doc/source/modules/gui/fit/index.rst
@@ -99,6 +113,8 @@ doc/source/modules/gui/plot/getting_started.rst
doc/source/modules/gui/plot/imageview.rst
doc/source/modules/gui/plot/index.rst
doc/source/modules/gui/plot/items.rst
+doc/source/modules/gui/plot/plotsignal.rst
+doc/source/modules/gui/plot/plottoolbuttons.rst
doc/source/modules/gui/plot/plottools.rst
doc/source/modules/gui/plot/plotwidget.rst
doc/source/modules/gui/plot/plotwindow.rst
@@ -141,18 +157,22 @@ doc/source/modules/gui/plot3d/actions.rst
doc/source/modules/gui/plot3d/dev.rst
doc/source/modules/gui/plot3d/glutils.rst
doc/source/modules/gui/plot3d/index.rst
+doc/source/modules/gui/plot3d/items.rst
doc/source/modules/gui/plot3d/plot3dwidget.rst
doc/source/modules/gui/plot3d/plot3dwindow.rst
doc/source/modules/gui/plot3d/scalarfieldview.rst
doc/source/modules/gui/plot3d/scene.rst
+doc/source/modules/gui/plot3d/scenewidget.rst
+doc/source/modules/gui/plot3d/scenewindow.rst
doc/source/modules/gui/plot3d/sfviewparamtree.rst
doc/source/modules/gui/plot3d/tools.rst
doc/source/modules/gui/plot3d/utils.rst
-doc/source/modules/gui/plot3d/viewer3dvolume_example.rst
doc/source/modules/gui/plot3d/img/Plot3DWidget.png
doc/source/modules/gui/plot3d/img/Plot3DWindow.png
doc/source/modules/gui/plot3d/img/SFViewParamTree.png
doc/source/modules/gui/plot3d/img/ScalarFieldView.png
+doc/source/modules/gui/plot3d/img/SceneWidget.png
+doc/source/modules/gui/plot3d/img/SceneWindow.png
doc/source/modules/gui/widgets/framebrowser.rst
doc/source/modules/gui/widgets/index.rst
doc/source/modules/gui/widgets/periodictable.rst
@@ -185,6 +205,7 @@ doc/source/modules/io/octaveh5.rst
doc/source/modules/io/specfile.rst
doc/source/modules/io/specfilewrapper.rst
doc/source/modules/io/spech5.rst
+doc/source/modules/io/url.rst
doc/source/modules/io/utils.rst
doc/source/modules/math/combo.rst
doc/source/modules/math/histogram.rst
@@ -199,21 +220,35 @@ doc/source/modules/math/fit/functions.rst
doc/source/modules/math/fit/index.rst
doc/source/modules/math/fit/leastsq.rst
doc/source/modules/math/fit/peaksearch.rst
+doc/source/modules/opencl/codec_cbf.rst
+doc/source/modules/opencl/fbp.rst
+doc/source/modules/opencl/index.rst
+doc/source/modules/opencl/medfilt.rst
+doc/source/modules/opencl/sift/align.rst
+doc/source/modules/opencl/sift/index.rst
+doc/source/modules/opencl/sift/match.rst
+doc/source/modules/opencl/sift/plan.rst
doc/source/modules/test/index.rst
doc/source/modules/utils/array_like.rst
doc/source/modules/utils/decorators.rst
doc/source/modules/utils/html.rst
doc/source/modules/utils/index.rst
+doc/source/modules/utils/testutils.rst
doc/source/modules/utils/weakref.rst
doc/source/sample_code/index.rst
doc/source/sample_code/img/animatedicons.png
+doc/source/sample_code/img/colormapDialog.png
+doc/source/sample_code/img/customDataView.png
doc/source/sample_code/img/customHdf5TreeModel.png
doc/source/sample_code/img/fftPlotAction.png
+doc/source/sample_code/img/fileDialog.png
doc/source/sample_code/img/hdf5widget.png
doc/source/sample_code/img/icons.png
doc/source/sample_code/img/imageview.png
doc/source/sample_code/img/periodicTable.png
doc/source/sample_code/img/plot3dContextMenu.png
+doc/source/sample_code/img/plot3dSceneWindow.png
+doc/source/sample_code/img/plotClearAction.png
doc/source/sample_code/img/plotContextMenu.png
doc/source/sample_code/img/plotItemsSelector.png
doc/source/sample_code/img/plotLimits.png
@@ -226,15 +261,19 @@ doc/source/sample_code/img/simplewidget.png
doc/source/sample_code/img/stackView.png
doc/source/sample_code/img/syncaxis.png
doc/source/sample_code/img/viewer3DVolume.png
-examples/animatedicons.py
+examples/colormapDialog.py
+examples/customDataView.py
examples/customHdf5TreeModel.py
examples/fft.png
examples/fftPlotAction.py
+examples/fileDialog.py
examples/hdf5widget.py
examples/icons.py
examples/imageview.py
examples/periodicTable.py
examples/plot3dContextMenu.py
+examples/plot3dSceneWindow.py
+examples/plotClearAction.py
examples/plotContextMenu.py
examples/plotItemsSelector.py
examples/plotLimits.py
@@ -271,6 +310,7 @@ package/debian9/source/options
package/desktop/org.silx.SilxView.desktop
package/desktop/silx.png
package/desktop/silx.svg
+package/desktop/silx.xml
qtdesigner_plugins/README.rst
qtdesigner_plugins/plot1dplugin.py
qtdesigner_plugins/plot2dplugin.py
@@ -329,6 +369,18 @@ silx/gui/data/test/test_arraywidget.py
silx/gui/data/test/test_dataviewer.py
silx/gui/data/test/test_numpyaxesselector.py
silx/gui/data/test/test_textformatter.py
+silx/gui/dialog/AbstractDataFileDialog.py
+silx/gui/dialog/DataFileDialog.py
+silx/gui/dialog/FileTypeComboBox.py
+silx/gui/dialog/ImageFileDialog.py
+silx/gui/dialog/SafeFileIconProvider.py
+silx/gui/dialog/SafeFileSystemModel.py
+silx/gui/dialog/__init__.py
+silx/gui/dialog/setup.py
+silx/gui/dialog/utils.py
+silx/gui/dialog/test/__init__.py
+silx/gui/dialog/test/test_datafiledialog.py
+silx/gui/dialog/test/test_imagefiledialog.py
silx/gui/fit/BackgroundWidget.py
silx/gui/fit/FitConfig.py
silx/gui/fit/FitWidget.py
@@ -409,6 +461,7 @@ silx/gui/plot/backends/glutils/PlotImageFile.py
silx/gui/plot/backends/glutils/__init__.py
silx/gui/plot/items/__init__.py
silx/gui/plot/items/axis.py
+silx/gui/plot/items/complex.py
silx/gui/plot/items/core.py
silx/gui/plot/items/curve.py
silx/gui/plot/items/histogram.py
@@ -439,23 +492,39 @@ silx/gui/plot/test/testPlotWidget.py
silx/gui/plot/test/testPlotWidgetNoBackend.py
silx/gui/plot/test/testPlotWindow.py
silx/gui/plot/test/testProfile.py
+silx/gui/plot/test/testSaveAction.py
silx/gui/plot/test/testScatterMaskToolsWidget.py
silx/gui/plot/test/testStackView.py
silx/gui/plot/test/testUtilsAxis.py
silx/gui/plot/test/utils.py
silx/gui/plot/utils/__init__.py
silx/gui/plot/utils/axis.py
+silx/gui/plot3d/ParamTreeView.py
silx/gui/plot3d/Plot3DWidget.py
silx/gui/plot3d/Plot3DWindow.py
silx/gui/plot3d/SFViewParamTree.py
silx/gui/plot3d/ScalarFieldView.py
+silx/gui/plot3d/SceneWidget.py
+silx/gui/plot3d/SceneWindow.py
silx/gui/plot3d/__init__.py
silx/gui/plot3d/setup.py
+silx/gui/plot3d/_model/__init__.py
+silx/gui/plot3d/_model/core.py
+silx/gui/plot3d/_model/items.py
+silx/gui/plot3d/_model/model.py
silx/gui/plot3d/actions/Plot3DAction.py
silx/gui/plot3d/actions/__init__.py
silx/gui/plot3d/actions/io.py
silx/gui/plot3d/actions/mode.py
silx/gui/plot3d/actions/viewpoint.py
+silx/gui/plot3d/items/__init__.py
+silx/gui/plot3d/items/clipplane.py
+silx/gui/plot3d/items/core.py
+silx/gui/plot3d/items/image.py
+silx/gui/plot3d/items/mesh.py
+silx/gui/plot3d/items/mixins.py
+silx/gui/plot3d/items/scatter.py
+silx/gui/plot3d/items/volume.py
silx/gui/plot3d/scene/__init__.py
silx/gui/plot3d/scene/axes.py
silx/gui/plot3d/scene/camera.py
@@ -477,6 +546,7 @@ silx/gui/plot3d/scene/test/test_utils.py
silx/gui/plot3d/test/__init__.py
silx/gui/plot3d/test/testGL.py
silx/gui/plot3d/test/testScalarFieldView.py
+silx/gui/plot3d/tools/GroupPropertiesWidget.py
silx/gui/plot3d/tools/ViewpointTools.py
silx/gui/plot3d/tools/__init__.py
silx/gui/plot3d/tools/toolbars.py
@@ -546,6 +616,7 @@ silx/io/specfile_wrapper.pxd
silx/io/specfilewrapper.py
silx/io/spech5.py
silx/io/spectoh5.py
+silx/io/url.py
silx/io/utils.py
silx/io/specfile/include/Lists.h
silx/io/specfile/include/SpecFile.h
@@ -573,6 +644,7 @@ silx/io/test/test_specfile.py
silx/io/test/test_specfilewrapper.py
silx/io/test/test_spech5.py
silx/io/test/test_spectoh5.py
+silx/io/test/test_url.py
silx/io/test/test_utils.py
silx/math/__init__.py
silx/math/calibration.py
@@ -650,6 +722,7 @@ silx/math/test/test_marchingcubes.py
silx/opencl/__init__.py
silx/opencl/backprojection.py
silx/opencl/common.py
+silx/opencl/image.py
silx/opencl/linalg.py
silx/opencl/medfilt.py
silx/opencl/processing.py
@@ -657,6 +730,11 @@ silx/opencl/projection.py
silx/opencl/reconstruction.py
silx/opencl/setup.py
silx/opencl/utils.py
+silx/opencl/codec/__init__.py
+silx/opencl/codec/byte_offset.py
+silx/opencl/codec/setup.py
+silx/opencl/codec/test/__init__.py
+silx/opencl/codec/test/test_byte_offset.py
silx/opencl/sift/__init__.py
silx/opencl/sift/alignment.py
silx/opencl/sift/match.py
@@ -682,6 +760,7 @@ silx/opencl/test/__init__.py
silx/opencl/test/test_addition.py
silx/opencl/test/test_array_utils.py
silx/opencl/test/test_backprojection.py
+silx/opencl/test/test_image.py
silx/opencl/test/test_linalg.py
silx/opencl/test/test_medfilt.py
silx/opencl/test/test_projection.py
@@ -712,6 +791,12 @@ silx/resources/gui/icons/close.png
silx/resources/gui/icons/close.svg
silx/resources/gui/icons/colorbar.png
silx/resources/gui/icons/colorbar.svg
+silx/resources/gui/icons/colormap-histogram.png
+silx/resources/gui/icons/colormap-histogram.svg
+silx/resources/gui/icons/colormap-none.png
+silx/resources/gui/icons/colormap-none.svg
+silx/resources/gui/icons/colormap-range.png
+silx/resources/gui/icons/colormap-range.svg
silx/resources/gui/icons/colormap.png
silx/resources/gui/icons/colormap.svg
silx/resources/gui/icons/crop.png
@@ -814,6 +899,8 @@ silx/resources/gui/icons/math-sigma.png
silx/resources/gui/icons/math-sigma.svg
silx/resources/gui/icons/math-smooth.png
silx/resources/gui/icons/math-smooth.svg
+silx/resources/gui/icons/math-square-amplitude.png
+silx/resources/gui/icons/math-square-amplitude.svg
silx/resources/gui/icons/math-substract.png
silx/resources/gui/icons/math-substract.svg
silx/resources/gui/icons/math-swap-sign.png
@@ -983,15 +1070,20 @@ silx/resources/opencl/linalg.cl
silx/resources/opencl/medfilt.cl
silx/resources/opencl/preprocess.cl
silx/resources/opencl/proj.cl
+silx/resources/opencl/codec/byte_offset.cl
+silx/resources/opencl/image/cast.cl
+silx/resources/opencl/image/histogram.cl
+silx/resources/opencl/image/map.cl
+silx/resources/opencl/image/max_min.cl
silx/resources/opencl/sift/addition.cl
silx/resources/opencl/sift/algebra.cl
silx/resources/opencl/sift/convolution.cl
+silx/resources/opencl/sift/descriptor_cpu.cl
+silx/resources/opencl/sift/descriptor_gpu1.cl
+silx/resources/opencl/sift/descriptor_gpu2.cl
silx/resources/opencl/sift/gaussian.cl
silx/resources/opencl/sift/image.cl
silx/resources/opencl/sift/interpolation.cl
-silx/resources/opencl/sift/keypoints_cpu.cl
-silx/resources/opencl/sift/keypoints_gpu1.cl
-silx/resources/opencl/sift/keypoints_gpu2.cl
silx/resources/opencl/sift/matching_cpu.cl
silx/resources/opencl/sift/matching_gpu.cl
silx/resources/opencl/sift/memset.cl
@@ -999,9 +1091,11 @@ silx/resources/opencl/sift/orientation_cpu.cl
silx/resources/opencl/sift/orientation_gpu.cl
silx/resources/opencl/sift/preprocess.cl
silx/resources/opencl/sift/reductions.cl
+silx/resources/opencl/sift/sift.cl
silx/resources/opencl/sift/transform.cl
silx/sx/__init__.py
silx/sx/_plot.py
+silx/sx/_plot3d.py
silx/test/__init__.py
silx/test/test_resources.py
silx/test/test_sx.py
@@ -1010,19 +1104,62 @@ silx/test/utils.py
silx/third_party/EdfFile.py
silx/third_party/TiffIO.py
silx/third_party/__init__.py
+silx/third_party/concurrent_futures.py
silx/third_party/enum.py
+silx/third_party/scipy_spatial.py
silx/third_party/setup.py
silx/third_party/six.py
silx/third_party/_local/__init__.py
silx/third_party/_local/enum.py
silx/third_party/_local/six.py
+silx/third_party/_local/concurrent_futures/__init__.py
+silx/third_party/_local/concurrent_futures/_base.py
+silx/third_party/_local/concurrent_futures/process.py
+silx/third_party/_local/concurrent_futures/thread.py
+silx/third_party/_local/scipy_spatial/__init__.py
+silx/third_party/_local/scipy_spatial/qhull.c
+silx/third_party/_local/scipy_spatial/qhull.pxd
+silx/third_party/_local/scipy_spatial/qhull.pyx
+silx/third_party/_local/scipy_spatial/setlist.pxd
+silx/third_party/_local/scipy_spatial/setup.py
+silx/third_party/_local/scipy_spatial/qhull/src/geom2_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/geom_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/geom_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/global_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/io_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/io_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/libqhull_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/libqhull_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/mem_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/mem_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/merge_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/merge_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/poly2_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/poly_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/poly_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/qhull_ra.h
+silx/third_party/_local/scipy_spatial/qhull/src/qset_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/qset_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/random_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/random_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/rboxlib_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/stat_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/stat_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/user_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/user_r.h
+silx/third_party/_local/scipy_spatial/qhull/src/usermem_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/userprintf_r.c
+silx/third_party/_local/scipy_spatial/qhull/src/userprintf_rbox_r.c
silx/utils/__init__.py
silx/utils/array_like.py
silx/utils/deprecation.py
+silx/utils/exceptions.py
silx/utils/html.py
silx/utils/launcher.py
+silx/utils/property.py
silx/utils/proxy.py
silx/utils/setup.py
+silx/utils/testutils.py
silx/utils/weakref.py
silx/utils/test/__init__.py
silx/utils/test/test_array_like.py