summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rw-r--r--debian/control1
-rw-r--r--debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch2
-rw-r--r--debian/patches/0004-skip-two-tests.patch29
-rw-r--r--debian/patches/0005-removed-hdf5plugin-from-full-dependencies.patch20
-rw-r--r--debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch4
-rw-r--r--debian/patches/series2
-rw-r--r--setup.py1
-rw-r--r--src/silx/io/test/test_h5py_utils.py2
9 files changed, 15 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog
index 4dd12fe..b573a3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+silx (1.1.2+dfsg-2) unstable; urgency=medium
+
+ * d/control: Added B-D python3-hdf5plugin.
+ * d/p/0004-skip-two-tests.patch: removed since upstream propose somethinf equivalent.
+ * d/p/0005-removed-hdf5plugin-from-full-dependencies.patch: Removed, hdf5plugin is
+ now available in Debian.
+
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Fri, 23 Jun 2023 09:36:20 +0200
+
silx (1.1.2+dfsg-1) unstable; urgency=medium
[ Stefano Rivera ]
@@ -11,7 +20,7 @@ silx (1.1.2+dfsg-1) unstable; urgency=medium
* d/t/control: Added python3-pytest-mock
* d/control: Added B-D pybuild-plugin-pyproject to avoid setup.py build
- -- Picca Frédéric-Emmanuel <picca@debian.org> Fri, 16 Jun 2023 14:35:33 +0200
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Fri, 23 Jun 2023 09:10:22 +0200
silx (1.1.0+dfsg-5) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 8e7c06e..192734e 100644
--- a/debian/control
+++ b/debian/control
@@ -18,6 +18,7 @@ Build-Depends:
python3-all-dev,
python3-fabio,
python3-h5py,
+ python3-hdf5plugin,
python3-mako,
python3-matplotlib,
python3-numpy,
diff --git a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
index 6453274..5213b7a 100644
--- a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+++ b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
@@ -7,7 +7,7 @@ Subject: do not modify PYTHONPATH from setup.py
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 527c072..04599d9 100644
+index 531070d..8b4d615 100644
--- a/setup.py
+++ b/setup.py
@@ -229,7 +229,8 @@ class BuildMan(Command):
diff --git a/debian/patches/0004-skip-two-tests.patch b/debian/patches/0004-skip-two-tests.patch
deleted file mode 100644
index fbef5d1..0000000
--- a/debian/patches/0004-skip-two-tests.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@debian.org>
-Date: Sun, 19 Sep 2021 16:03:58 +0200
-Subject: skip two tests
-
-"https://github.com/silx-kit/silx/issues/3523"
----
- src/silx/io/test/test_h5py_utils.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/silx/io/test/test_h5py_utils.py b/src/silx/io/test/test_h5py_utils.py
-index 0d10a78..f6405c6 100644
---- a/src/silx/io/test/test_h5py_utils.py
-+++ b/src/silx/io/test/test_h5py_utils.py
-@@ -248,6 +248,7 @@ class TestH5pyUtils(unittest.TestCase):
- "Versions of libhdf5 and h5py use incompatible file locking behaviour",
- )
- @subtests
-+ @unittest.skipIf(True, "https://github.com/silx-kit/silx/issues/3523")
- def test_modes_multi_process(self):
- """Test concurrent access to the same file from different processes"""
- filename = self._new_filename()
-@@ -322,6 +323,7 @@ class TestH5pyUtils(unittest.TestCase):
-
- @subtests
- @unittest.skipIf(not h5py_utils.HAS_SWMR, "SWMR not supported")
-+ @unittest.skipIf(True, "https://github.com/silx-kit/silx/issues/3523")
- def test_modes_multi_process_swmr(self):
- filename = self._new_filename()
-
diff --git a/debian/patches/0005-removed-hdf5plugin-from-full-dependencies.patch b/debian/patches/0005-removed-hdf5plugin-from-full-dependencies.patch
deleted file mode 100644
index d1965e0..0000000
--- a/debian/patches/0005-removed-hdf5plugin-from-full-dependencies.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= <picca@debian.org>
-Date: Thu, 10 Feb 2022 15:14:41 +0100
-Subject: removed hdf5plugin from full dependencies
-
----
- setup.py | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 04599d9..18e10cc 100644
---- a/setup.py
-+++ b/setup.py
-@@ -516,7 +516,6 @@ def get_project_configuration():
- 'python-dateutil',
- 'PyQt5',
- # extra
-- 'hdf5plugin',
- 'scipy',
- 'Pillow']
-
diff --git a/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch b/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch
index 7e0b287..d6d9321 100644
--- a/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch
+++ b/debian/patches/0007-do-not-install-scipy_spatial-COPYING.txt.patch
@@ -7,10 +7,10 @@ Subject: do not install scipy_spatial COPYING.txt
1 file changed, 3 deletions(-)
diff --git a/setup.py b/setup.py
-index 18e10cc..523333f 100644
+index 8b4d615..d66eef5 100644
--- a/setup.py
+++ b/setup.py
-@@ -787,9 +787,6 @@ def get_project_configuration():
+@@ -789,9 +789,6 @@ def get_project_configuration():
},
ext_modules=ext_modules,
package_data=package_data,
diff --git a/debian/patches/series b/debian/patches/series
index dccb14e..abee63a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,8 +1,6 @@
0002-use-the-system-mathjax-privacy-breach.patch
0003-do-not-modify-PYTHONPATH-from-setup.py.patch
0006-Tests-if-openCL-can-be-used.patch
-0004-skip-two-tests.patch
-0005-removed-hdf5plugin-from-full-dependencies.patch
0007-python3.10-fix.patch
0007-do-not-install-scipy_spatial-COPYING.txt.patch
0008-python3.11-fix.patch
diff --git a/setup.py b/setup.py
index 8f838c4..d66eef5 100644
--- a/setup.py
+++ b/setup.py
@@ -516,6 +516,7 @@ def get_project_configuration():
'python-dateutil',
'PyQt5',
# extra
+ 'hdf5plugin',
'scipy',
'Pillow']
diff --git a/src/silx/io/test/test_h5py_utils.py b/src/silx/io/test/test_h5py_utils.py
index f6405c6..0d10a78 100644
--- a/src/silx/io/test/test_h5py_utils.py
+++ b/src/silx/io/test/test_h5py_utils.py
@@ -248,7 +248,6 @@ class TestH5pyUtils(unittest.TestCase):
"Versions of libhdf5 and h5py use incompatible file locking behaviour",
)
@subtests
- @unittest.skipIf(True, "https://github.com/silx-kit/silx/issues/3523")
def test_modes_multi_process(self):
"""Test concurrent access to the same file from different processes"""
filename = self._new_filename()
@@ -323,7 +322,6 @@ class TestH5pyUtils(unittest.TestCase):
@subtests
@unittest.skipIf(not h5py_utils.HAS_SWMR, "SWMR not supported")
- @unittest.skipIf(True, "https://github.com/silx-kit/silx/issues/3523")
def test_modes_multi_process_swmr(self):
filename = self._new_filename()