summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rw-r--r--debian/control2
-rw-r--r--debian/patches/0005-slocale.h-is-removed-in-GLIBC-2.26.patch44
-rw-r--r--debian/patches/series1
-rw-r--r--silx/io/specfile/src/locale_management.c24
5 files changed, 72 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c09f67..2d807a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+silx (0.6.1+dfsg-2) unstable; urgency=medium
+
+ * d/control
+ - Bump Standrad-Version 4.1.1 (nothing to do)
+ * fixed glibc 2.26 FTBFS with upstream patch glib2.26 (Closes: #882881)
+ * d/patches
+ + 0005-slocale.h-is-removed-in-GLIBC-2.26.patch (Added)
+
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 21 Jan 2018 09:32:38 +0100
+
silx (0.6.1+dfsg-1) unstable; urgency=medium
* New upstream version 0.6.1+dfsg
diff --git a/debian/control b/debian/control
index 2adc2a8..e2a6a87 100644
--- a/debian/control
+++ b/debian/control
@@ -73,7 +73,7 @@ Build-Depends: cython (>= 0.23.2),
python3-sphinxcontrib.programoutput,
xauth,
xvfb
-Standards-Version: 4.0.1
+Standards-Version: 4.1.1
Vcs-Browser: https://anonscm.debian.org/cgit/debian-science/packages/silx.git
Vcs-Git: https://anonscm.debian.org/git/debian-science/packages/silx.git
Homepage: https://github.com/silx-kit/silx
diff --git a/debian/patches/0005-slocale.h-is-removed-in-GLIBC-2.26.patch b/debian/patches/0005-slocale.h-is-removed-in-GLIBC-2.26.patch
new file mode 100644
index 0000000..fb081bb
--- /dev/null
+++ b/debian/patches/0005-slocale.h-is-removed-in-GLIBC-2.26.patch
@@ -0,0 +1,44 @@
+From: Vicente Armando Sole <sole@titan.esrf.fr>
+Date: Mon, 27 Nov 2017 10:46:30 +0100
+Subject: slocale.h is removed in GLIBC 2.26
+
+---
+ silx/io/specfile/src/locale_management.c | 24 ++++++++++++++++--------
+ 1 file changed, 16 insertions(+), 8 deletions(-)
+
+diff --git a/silx/io/specfile/src/locale_management.c b/silx/io/specfile/src/locale_management.c
+index 163ed75..62111cc 100644
+--- a/silx/io/specfile/src/locale_management.c
++++ b/silx/io/specfile/src/locale_management.c
+@@ -24,15 +24,23 @@
+ #include <stdlib.h>
+
+ #ifdef _GNU_SOURCE
+-#include <xlocale.h>
+-#include <locale.h>
++# include <locale.h>
++# ifdef __GLIBC__
++# include <features.h>
++# if !((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ > 25)))
++# /* strtod_l has been moved to stdlib.h since glibc 2.26 */
++# include <xlocale.h>
++# endif
++# else
++# include <xlocale.h>
++# endif
+ #else
+-#ifdef PYMCA_POSIX
+-#else
+-#ifdef SPECFILE_POSIX
+-#include <locale.h>
+-#endif
+-#endif
++# ifdef PYMCA_POSIX
++# else
++# ifdef SPECFILE_POSIX
++# include <locale.h>
++# endif
++# endif
+ #endif
+
+ #include <string.h>
diff --git a/debian/patches/series b/debian/patches/series
index b1878a6..820176e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
0003-fix-unit-test.patch
0006-prefer-pyqt5-over-pyside.patch
0007-add-install_requires-dependencies.patch
+0005-slocale.h-is-removed-in-GLIBC-2.26.patch
diff --git a/silx/io/specfile/src/locale_management.c b/silx/io/specfile/src/locale_management.c
index 163ed75..62111cc 100644
--- a/silx/io/specfile/src/locale_management.c
+++ b/silx/io/specfile/src/locale_management.c
@@ -24,15 +24,23 @@
#include <stdlib.h>
#ifdef _GNU_SOURCE
-#include <xlocale.h>
-#include <locale.h>
+# include <locale.h>
+# ifdef __GLIBC__
+# include <features.h>
+# if !((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ > 25)))
+# /* strtod_l has been moved to stdlib.h since glibc 2.26 */
+# include <xlocale.h>
+# endif
+# else
+# include <xlocale.h>
+# endif
#else
-#ifdef PYMCA_POSIX
-#else
-#ifdef SPECFILE_POSIX
-#include <locale.h>
-#endif
-#endif
+# ifdef PYMCA_POSIX
+# else
+# ifdef SPECFILE_POSIX
+# include <locale.h>
+# endif
+# endif
#endif
#include <string.h>