summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/tests/gui16
2 files changed, 17 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 66cdcae..aa319b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+silx (2.0.1+dfsg-3) unstable; urgency=medium
+
+ * d/t/gui: do not fail if the return value is 134. until we figure out
+ what is going on with mesa and xvfb.
+
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Tue, 16 Apr 2024 10:47:09 +0200
+
silx (2.0.1+dfsg-2) unstable; urgency=medium
* d/t/control: rework the gui test in order to make it work with
diff --git a/debian/tests/gui b/debian/tests/gui
index c204243..f5c0a5b 100755
--- a/debian/tests/gui
+++ b/debian/tests/gui
@@ -1,4 +1,4 @@
-#!/bin/sh -e
+#!/bin/sh -ex
# display glxinfo
@@ -6,10 +6,14 @@ glxinfo
# Check that the GUI can be started
-CMD="timeout --preserve-status 5s silx view"
-echo $CMD
-$($CMD)
+timeout --preserve-status 5s silx view
+ec=$?
-# skip the test for now
+# do not fail if the exit code is 143, it seems that there is an
+# issue with mesa 16/04/2024.
-$?
+if [ $ec -eq 143 ]; then
+ exit 0;
+else
+ exit $ec;
+fi