summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch4
-rw-r--r--debian/patches/0003-fix-unit-test.patch29
-rw-r--r--debian/patches/0006-Tests-if-openCL-can-be-used.patch29
-rw-r--r--debian/patches/series1
4 files changed, 13 insertions, 50 deletions
diff --git a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
index 4591cb6..78446f3 100644
--- a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+++ b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
@@ -7,10 +7,10 @@ Subject: do not modify PYTHONPATH from setup.py
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 1029bf0..46d0bdf 100644
+index 86ae5bb..a7f3f2a 100644
--- a/setup.py
+++ b/setup.py
-@@ -260,7 +260,8 @@ class BuildMan(Command):
+@@ -261,7 +261,8 @@ class BuildMan(Command):
path.insert(0, os.path.abspath(build.build_lib))
env = dict((str(k), str(v)) for k, v in os.environ.items())
diff --git a/debian/patches/0003-fix-unit-test.patch b/debian/patches/0003-fix-unit-test.patch
deleted file mode 100644
index 4e4f77f..0000000
--- a/debian/patches/0003-fix-unit-test.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
- <picca@synchrotron-soleil.fr>
-Date: Fri, 11 Aug 2017 10:15:26 +0200
-Subject: fix unit test
-
----
- silx/opencl/common.py | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/silx/opencl/common.py b/silx/opencl/common.py
-index 8d31c8a..1f9df50 100644
---- a/silx/opencl/common.py
-+++ b/silx/opencl/common.py
-@@ -61,7 +61,14 @@ else:
- pyopencl = None
- else:
- import pyopencl.array as array
-- mf = pyopencl.mem_flags
-+
-+if pyopencl is None:
-+ class mf(object):
-+ WRITE_ONLY = 1
-+ READ_ONLY = 1
-+ READ_WRITE = 1
-+else:
-+ mf = pyopencl.mem_flags
-
- if pyopencl is None:
- # Define default mem flags
diff --git a/debian/patches/0006-Tests-if-openCL-can-be-used.patch b/debian/patches/0006-Tests-if-openCL-can-be-used.patch
index 52a8c93..78a3bf8 100644
--- a/debian/patches/0006-Tests-if-openCL-can-be-used.patch
+++ b/debian/patches/0006-Tests-if-openCL-can-be-used.patch
@@ -3,26 +3,19 @@ Date: Fri, 5 Jul 2019 16:52:20 +0200
Subject: Tests if openCL can be used
---
- silx/opencl/common.py | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
+ silx/opencl/common.py | 2 ++
+ 1 file changed, 2 insertions(+)
diff --git a/silx/opencl/common.py b/silx/opencl/common.py
-index 1f9df50..73cf676 100644
+index 110d941..3525bf4 100644
--- a/silx/opencl/common.py
+++ b/silx/opencl/common.py
-@@ -60,7 +60,14 @@ else:
- logger.warning("Unable to import pyOpenCl. Please install it from: http://pypi.python.org/pypi/pyopencl")
- pyopencl = None
- else:
-- import pyopencl.array as array
-+ try:
-+ pyopencl.get_platforms()
-+ except pyopencl.LogicError:
-+ logger.warning("The module pyOpenCL has been imported but can't be used here")
-+ pyopencl = None
-+ else:
-+ import pyopencl.array as array
-+ mf = pyopencl.mem_flags
+@@ -75,6 +75,8 @@ if pyopencl is None:
+ WRITE_ONLY = 1
+ READ_ONLY = 1
+ READ_WRITE = 1
++else:
++ mf = pyopencl.mem_flags
- if pyopencl is None:
- class mf(object):
+
+ FLOP_PER_CORE = {"GPU": 64, # GPU, Fermi at least perform 64 flops per cycle/multicore, G80 were at 24 or 48 ...
diff --git a/debian/patches/series b/debian/patches/series
index 1b65e43..efd273e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
0002-use-the-system-mathjax-privacy-breach.patch
-0003-fix-unit-test.patch
0003-do-not-modify-PYTHONPATH-from-setup.py.patch
0006-Tests-if-openCL-can-be-used.patch