summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/tests/control.autodep88
2 files changed, 10 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index cff8d61..1019ff6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+silx (0.9.0+dfsg-2) unstable; urgency=medium
+
+ * d/t/control.autodep8: Fixed to run test for real.
+
+ --
+
silx (0.9.0+dfsg-1) unstable; urgency=medium
[ Picca Frédéric-Emmanuel ]
diff --git a/debian/tests/control.autodep8 b/debian/tests/control.autodep8
index 5ffa42b..1e5cddf 100644
--- a/debian/tests/control.autodep8
+++ b/debian/tests/control.autodep8
@@ -2,7 +2,7 @@ Test-Command: set -efu
; for py in $(pyversions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -m unittest discover silx 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import silx.test; silx.test.run_tests()" 2>&1
; done
Depends: python-all, python-silx, xauth, xvfb
@@ -10,7 +10,7 @@ Test-Command: set -efu
; for py in $(pyversions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py-dbg:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -m unittest discover silx 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -c "import silx.test; silx.test.run_tests()" 2>&1
; done
Depends: python-all-dbg, python-silx-dbg, xauth, xvfb
@@ -18,7 +18,7 @@ Test-Command: set -efu
; for py in $(py3versions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -m unittest discover silx 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import silx.test; silx.test.run_tests()" 2>&1
; done
Depends: python3-all, python3-silx, xauth, xvfb
@@ -26,6 +26,6 @@ Test-Command: set -efu
; for py in $(py3versions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py-dbg:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -m unittest discover silx 2>&1
+ ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -c "import silx.test; silx.test.run_tests()" 2>&1
; done
Depends: python3-all-dbg, python3-silx-dbg, xauth, xvfb