summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/tests/python24
-rwxr-xr-xdebian/tests/python2-dbg4
-rwxr-xr-xdebian/tests/python34
-rwxr-xr-xdebian/tests/python3-dbg4
5 files changed, 11 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index be81d6c..320bbe8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
silx (0.8.0+dfsg-2) UNRELEASED; urgency=medium
- * Add autopkgtests
+ * Fixed autopkgtests
+ * Use salsa-ci for continuous integration.
- -- Picca Frédéric-Emmanuel <picca@debian.org> Tue, 31 Jul 2018 16:24:57 +0200
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 05 Aug 2018 08:11:46 +0200
silx (0.8.0+dfsg-1) unstable; urgency=medium
diff --git a/debian/tests/python2 b/debian/tests/python2
index 31e3d64..39734a1 100755
--- a/debian/tests/python2
+++ b/debian/tests/python2
@@ -5,10 +5,10 @@ export LC_ALL=C.UTF-8
pys="$(pyversions -rv 2> /dev/null)"
-cp -a tests "$AUTOPKGTEST_TMP"
+cp -a silx/test "$AUTOPKGTEST_TMP"
cd "$AUTOPKGTEST_TMP"
for py in $pys; do
echo "=== python$py ==="
- python$py -m unittest discover silx/test/ 2>&1
+ python$py -m unittest discover test/ 2>&1
done
diff --git a/debian/tests/python2-dbg b/debian/tests/python2-dbg
index f43398e..0c86b9a 100755
--- a/debian/tests/python2-dbg
+++ b/debian/tests/python2-dbg
@@ -5,10 +5,10 @@ export LC_ALL=C.UTF-8
pys="$(pyversions -rv 2> /dev/null)"
-cp -a tests "$AUTOPKGTEST_TMP"
+cp -a silx/test "$AUTOPKGTEST_TMP"
cd "$AUTOPKGTEST_TMP"
for py in $pys; do
echo "=== python$py ==="
- python$py-dbg -m unittest discover silx/test/ 2>&1
+ python$py-dbg -m unittest discover test/ 2>&1
done
diff --git a/debian/tests/python3 b/debian/tests/python3
index 51858b8..e63e9c5 100755
--- a/debian/tests/python3
+++ b/debian/tests/python3
@@ -5,10 +5,10 @@ export LC_ALL=C.UTF-8
pys="$(py3versions -rv 2> /dev/null)"
-cp -a tests "$AUTOPKGTEST_TMP"
+cp -a silx/test "$AUTOPKGTEST_TMP"
cd "$AUTOPKGTEST_TMP"
for py in $pys; do
echo "=== python$py ==="
- python$py -m unittest discover silx/test/ 2>&1
+ python$py -m unittest discover test/ 2>&1
done
diff --git a/debian/tests/python3-dbg b/debian/tests/python3-dbg
index d9c1208..ae791ae 100755
--- a/debian/tests/python3-dbg
+++ b/debian/tests/python3-dbg
@@ -5,10 +5,10 @@ export LC_ALL=C.UTF-8
pys="$(py3versions -rv 2> /dev/null)"
-cp -a tests "$AUTOPKGTEST_TMP"
+cp -a silx/test "$AUTOPKGTEST_TMP"
cd "$AUTOPKGTEST_TMP"
for py in $pys; do
echo "=== python$py ==="
- python$py-dbg -m unittest discover silx/test/ 2>&1
+ python$py-dbg -m unittest discover test/ 2>&1
done