summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/tests/control23
-rwxr-xr-xdebian/tests/gui5
-rwxr-xr-xdebian/tests/no-opencl9
-rwxr-xr-xdebian/tests/opencl18
5 files changed, 55 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 5be9cf7..31c1782 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+silx (2.0.0+dfsg-2) unstable; urgency=medium
+
+ * d/t/control: Split into opencl, no-opencl and gui scripts.
+ The opencl part is for now marked flaky.
+ * use POCL_WORK_GROUP_METHOD=cbs for tests.
+
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Mon, 11 Mar 2024 13:27:15 +0100
+
silx (2.0.0+dfsg-1) unstable; urgency=low
* Update standards version to 4.6.2, no changes needed.
diff --git a/debian/tests/control b/debian/tests/control
index b6381a0..2f21843 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,9 +1,4 @@
-Test-Command: set -efu
- ; for py in $(py3versions -r 2>/dev/null)
- ; do cd "$AUTOPKGTEST_TMP"
- ; echo "Testing with $py:"
- ; HOME="$AUTOPKGTEST_TMP" SILX_TEST_LOW_MEM=False xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import sys; import silx.test; sys.exit(silx.test.run_tests())" 2>&1
- ; done
+Tests: no-opencl
Depends:
@,
python3-all,
@@ -12,10 +7,22 @@ Depends:
python3-pytest-xvfb,
xauth,
xvfb,
+Restrictions: allow-stderr
+
+Tests: opencl
+Depends:
+ @,
+ clinfo,
+ python3-all,
+ python3-pytest,
+ python3-pytest-mock,
+ python3-pytest-xvfb,
+ xauth,
+ xvfb,
Architecture: !i386
+Restrictions: allow-stderr
-Test-Command: set -efu
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" timeout --preserve-status 5 silx view
+Tests: gui
Depends:
silx,
xauth,
diff --git a/debian/tests/gui b/debian/tests/gui
new file mode 100755
index 0000000..7fd5d5f
--- /dev/null
+++ b/debian/tests/gui
@@ -0,0 +1,5 @@
+#!/bin/sh -e
+
+# Check that the GUI can be stated
+
+xvfb-run -a --server-args="-screen 0 1024x768x24" timeout --preserve-status 5 silx view
diff --git a/debian/tests/no-opencl b/debian/tests/no-opencl
new file mode 100755
index 0000000..0041789
--- /dev/null
+++ b/debian/tests/no-opencl
@@ -0,0 +1,9 @@
+#!/bin/sh -e
+
+# run most of the test suite without the OpenCL part
+
+for py in $(py3versions -r 2>/dev/null)
+do cd "$AUTOPKGTEST_TMP"
+ echo "Testing with $py:"
+ HOME="$AUTOPKGTEST_TMP" SILX_OPENCL=False SILX_TEST_LOW_MEM=False xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import sys; import silx.test; sys.exit(silx.test.run_tests())" 2>&1
+done
diff --git a/debian/tests/opencl b/debian/tests/opencl
new file mode 100755
index 0000000..174bf4f
--- /dev/null
+++ b/debian/tests/opencl
@@ -0,0 +1,18 @@
+#!/bin/sh -e
+
+# Check that OpenCL isn't totally broken (note that it isn't totally working either)
+# Uses device 0 platform 0, i.e. to use a real GPU manually install its opencl-icd before running this
+# Mark the test has flaky, the important part is the CPU computation.
+
+# display the OpenCL platform info
+
+clinfo
+
+# until we solved https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1060318
+export POCL_WORK_GROUP_METHOD=cbs
+
+for py in $(py3versions -r 2>/dev/null)
+do cd "$AUTOPKGTEST_TMP"
+ echo "Testing with $py:"
+ HOME="$AUTOPKGTEST_TMP" WITH_QT_TEST=False SILX_TEST_LOW_MEM=False xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import sys; import silx.test; sys.exit(silx.test.run_tests())" 2>&1
+done