summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/tests/control2
3 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 3a58925..b55b37e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+silx (1.1.0+dfsg-3) unstable; urgency=medium
+
+ * do not run test which use lot's of memory
+
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Fri, 04 Nov 2022 16:54:24 +0100
+
silx (1.1.0+dfsg-2) unstable; urgency=medium
* fix a typo to avoid running test which use lot's of memory.
diff --git a/debian/rules b/debian/rules
index f1afe1c..0f9a149 100755
--- a/debian/rules
+++ b/debian/rules
@@ -52,11 +52,12 @@ execute_before_dh_install:
# WITH_QT_TEST=False to disable graphical tests
# SILX_OPENCL=False to disable OpenCL tests
-# SILX_TEST_LOW_MEM=True to disable tests taking large amount of memory
+# SILX_TEST_LOW_MEM=False to disable tests taking large amount of memory
# GPU=False to disable the use of a GPU with OpenCL test
# WITH_GL_TEST=False to disable tests using OpenGL
override_dh_auto_test:
- dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LOW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
+ GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LOW_MEM=False \
+ dh_auto_test
execute_after_dh_installdocs:
dh_installdocs -p python-silx-doc "doc/build/html" --doc-main-package=python3-silx
diff --git a/debian/tests/control b/debian/tests/control
index c77fbe8..4dcec27 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -2,7 +2,7 @@ Test-Command: set -efu
; for py in $(py3versions -r 2>/dev/null)
; do cd "$AUTOPKGTEST_TMP"
; echo "Testing with $py:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import sys; import silx.test; sys.exit(silx.test.run_tests())" 2>&1
+ ; SILX_TEST_LOW_MEM=False xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import sys; import silx.test; sys.exit(silx.test.run_tests())" 2>&1
; done
Depends:
@,