summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--debian/control60
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/tests/control8
4 files changed, 11 insertions, 76 deletions
diff --git a/debian/changelog b/debian/changelog
index 1adbef0..5898d9b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,11 @@
-silx (0.15.2+dfsg-1) unstable; urgency=medium
+silx (0.15.2+dfsg-2) unstable; urgency=medium
- * fix build options name nodocs -> nodoc
- * New upstream version 0.15.2+dfsg
- * refresh patch series.
- * d/control: Added dh-sequence[numpy3,python3,sphinxdoc]
+ * Bug fix: "Removal of the python3-*-dbg packages in sid/bookworm",
+ thanks to Matthias Klose (Closes: #994377).
+ * Bug fix: "drop unused *-dbg packages from Build-Depends", thanks to
+ Helmut Grohne (Closes: #980417).
- -- Picca Frédéric-Emmanuel <picca@debian.org> Wed, 08 Sep 2021 09:41:22 +0200
+ -- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 19 Sep 2021 14:07:44 +0200
silx (0.14.0+dfsg-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 282536c..0e40824 100644
--- a/debian/control
+++ b/debian/control
@@ -5,38 +5,27 @@ Uploaders: Jerome Kieffer <jerome.kieffer@esrf.fr>,
Alexandre Marie <alexandre.marie@synchrotron-soleil.fr>
Section: science
Priority: optional
-Build-Depends: cython3 (>= 0.23.2),
- cython3-dbg (>= 0.23.2),
- debhelper-compat (= 12),
+Build-Depends: cython3,
+ debhelper-compat (= 13),
dh-python,
dh-sequence-numpy3,
dh-sequence-python3,
help2man,
ipython3,
- python3-all-dbg,
python3-all-dev,
python3-fabio,
- python3-fabio-dbg,
python3-h5py,
- python3-h5py-dbg,
python3-mako,
python3-matplotlib,
- python3-matplotlib-dbg,
python3-numpy,
- python3-numpy-dbg,
python3-opengl,
python3-pil,
- python3-pil-dbg,
python3-pyopencl,
- python3-pyopencl-dbg,
- python3-pyqt5-dbg,
+ python3-pyqt5,
python3-pyqt5.qtopengl,
- python3-pyqt5.qtopengl-dbg,
python3-pyqt5.qtsvg,
- python3-pyqt5.qtsvg-dbg,
python3-qtconsole,
python3-scipy,
- python3-scipy-dbg,
python3-setuptools,
xauth,
xvfb
@@ -46,7 +35,7 @@ Build-Depends-Indep:
python3-nbsphinx <!nodoc>,
python3-sphinx,
python3-sphinxcontrib.programoutput,
-Standards-Version: 4.5.0
+Standards-Version: 4.5.1
Vcs-Browser: https://salsa.debian.org/science-team/silx
Vcs-Git: https://salsa.debian.org/science-team/silx.git
Homepage: https://github.com/silx-kit/silx
@@ -106,50 +95,11 @@ Description: Toolbox for X-Ray data analysis - Python3
.
This is the Python 3 version of the package.
-Package: python3-silx-dbg
-Architecture: any
-Section: debug
-Depends: python3-fabio-dbg,
- python3-h5py-dbg,
- python3-lxml-dbg,
- python3-matplotlib-dbg,
- python3-numpy-dbg,
- python3-pil-dbg,
- python3-pyopencl-dbg,
- python3-pyqt5-dbg,
- python3-pyqt5.qtopengl-dbg,
- python3-pyqt5.qtsvg-dbg,
- python3-scipy-dbg,
- python3-silx (= ${binary:Version}),
- ${misc:Depends},
- ${python3:Depends},
- ${shlibs:Depends}
-Description: Toolbox for X-Ray data analysis - Python3 debug
- The silx project aims at providing a collection of Python packages to
- support the development of data assessment, reduction and analysis
- applications at synchrotron radiation facilities. It aims at
- providing reading/writing different file formats, data reduction
- routines and a set of Qt widgets to browse and visualize data.
- .
- The current version provides :
- .
- * reading HDF5 file format (with support of SPEC file format)
- * histogramming
- * fitting
- * 1D and 2D visualization using multiple backends (matplotlib or OpenGL)
- * image plot widget with a set of associated tools (See changelog file).
- * Unified browser for HDF5, SPEC and image file formats supporting inspection
- and visualization of n-dimensional datasets.
- * Unified viewer (silx view filename) for HDF5, SPEC and image file formats
- * OpenGL-based widget to display 3D scalar field with
- isosurface and cutting plane.
- .
- This is the Python 3 debug version of the package.
-
Package: python-silx-doc
Architecture: all
Section: doc
Depends: libjs-mathjax, ${misc:Depends}, ${sphinxdoc:Depends}
+Multi-Arch: foreign
Description: Toolbox for X-Ray data analysis - Documentation
The silx project aims at providing a collection of Python packages to
support the development of data assessment, reduction and analysis
diff --git a/debian/rules b/debian/rules
index e4f1f87..58893e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,5 @@
#!/usr/bin/make -f
-# avoir bbuild FTBFS
-export HOME=$(CURDIR)/debian/tmp-home
-export XDG_RUNTIME_DIR=$(HOME)/runtime
-export POCL_CACHE_DIR=$(HOME)/.cache/
-
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
@@ -41,7 +36,6 @@ execute_after_dh_auto_build-indep:
# build the documentation
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
- mkdir -p -m 700 $(XDG_RUNTIME_DIR)
pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
endif
@@ -62,7 +56,6 @@ execute_before_dh_install:
# GPU=False to disable the use of a GPU with OpenCL test
# WITH_GL_TEST=False to disable tests using OpenGL
override_dh_auto_test:
- mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
execute_after_dh_installdocs:
diff --git a/debian/tests/control b/debian/tests/control
index deb174c..b6fa2c3 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -5,11 +5,3 @@ Test-Command: set -efu
; xvfb-run -a --server-args="-screen 0 1024x768x24" $py -c "import silx.test; silx.test.run_tests()" 2>&1
; done
Depends: python3-all, python3-silx, xauth, xvfb
-
-Test-Command: set -efu
- ; for py in $(py3versions -r 2>/dev/null)
- ; do cd "$AUTOPKGTEST_TMP"
- ; echo "Testing with $py-dbg:"
- ; xvfb-run -a --server-args="-screen 0 1024x768x24" $py-dbg -c "import silx.test; silx.test.run_tests()" 2>&1
- ; done
-Depends: python3-all-dbg, python3-silx-dbg, xauth, xvfb