summaryrefslogtreecommitdiff
path: root/debian/patches/0007-add-install_requires-dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0007-add-install_requires-dependencies.patch')
-rw-r--r--debian/patches/0007-add-install_requires-dependencies.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/patches/0007-add-install_requires-dependencies.patch b/debian/patches/0007-add-install_requires-dependencies.patch
new file mode 100644
index 0000000..940ac56
--- /dev/null
+++ b/debian/patches/0007-add-install_requires-dependencies.patch
@@ -0,0 +1,39 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 17 Aug 2017 09:30:39 +0200
+Subject: add install_requires dependencies
+
+---
+ setup.py | 19 ++++++++++++++++++-
+ 1 file changed, 18 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index bc7ea27..8c4dd3d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -857,7 +857,24 @@ def get_project_configuration(dry_run):
+ # for most of the computation
+ "numpy %s" % numpy_requested_version,
+ # for the script launcher
+- "setuptools"]
++ "setuptools",
++ # Debian added
++ 'futures;python_version<"3.2"',
++ "ipython",
++ "qtconsole",
++ 'enum34;python_version<"3.4"',
++ "fabio",
++ "h5py",
++ "lxml",
++ "mako",
++ "matplotlib",
++ "PyOpenGL",
++ "pil",
++ "pyopencl",
++ "PyQt5",
++ "scipy",
++ "six"
++ ]
+
+ setup_requires = ["setuptools", "numpy"]
+