summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch4
-rw-r--r--debian/patches/0004-skip-two-tests.patch22
-rw-r--r--debian/patches/0006-Tests-if-openCL-can-be-used.patch10
3 files changed, 18 insertions, 18 deletions
diff --git a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
index 2a43553..bdefa54 100644
--- a/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+++ b/debian/patches/0003-do-not-modify-PYTHONPATH-from-setup.py.patch
@@ -7,10 +7,10 @@ Subject: do not modify PYTHONPATH from setup.py
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 771374c..bc43c32 100644
+index 045b9a0..c095b89 100644
--- a/setup.py
+++ b/setup.py
-@@ -313,7 +313,8 @@ class BuildMan(Command):
+@@ -296,7 +296,8 @@ class BuildMan(Command):
path.insert(0, os.path.abspath(build.build_lib))
env = dict((str(k), str(v)) for k, v in os.environ.items())
diff --git a/debian/patches/0004-skip-two-tests.patch b/debian/patches/0004-skip-two-tests.patch
index 077e5ee..a62e77f 100644
--- a/debian/patches/0004-skip-two-tests.patch
+++ b/debian/patches/0004-skip-two-tests.patch
@@ -4,22 +4,22 @@ Subject: skip two tests
"https://github.com/silx-kit/silx/issues/3523"
---
- silx/io/test/test_h5py_utils.py | 2 ++
+ src/silx/io/test/test_h5py_utils.py | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/silx/io/test/test_h5py_utils.py b/silx/io/test/test_h5py_utils.py
-index 2e2e3dd..4a8e184 100644
---- a/silx/io/test/test_h5py_utils.py
-+++ b/silx/io/test/test_h5py_utils.py
-@@ -204,6 +204,7 @@ class TestH5pyUtils(unittest.TestCase):
- self.assertEqual(orig, os.environ.get("HDF5_USE_FILE_LOCKING"))
-
+diff --git a/src/silx/io/test/test_h5py_utils.py b/src/silx/io/test/test_h5py_utils.py
+index ea46eca..847a7b9 100644
+--- a/src/silx/io/test/test_h5py_utils.py
++++ b/src/silx/io/test/test_h5py_utils.py
+@@ -249,6 +249,7 @@ class TestH5pyUtils(unittest.TestCase):
+ "Versions of libhdf5 and h5py use incompatible file locking behaviour",
+ )
@subtests
+ @unittest.skipIf(True, "https://github.com/silx-kit/silx/issues/3523")
def test_modes_multi_process(self):
- if not self._liber_allows_concurrent_access:
- # A concurrent reader with HDF5_USE_FILE_LOCKING=FALSE is
-@@ -263,6 +264,7 @@ class TestH5pyUtils(unittest.TestCase):
+ """Test concurrent access to the same file from different processes"""
+ filename = self._new_filename()
+@@ -323,6 +324,7 @@ class TestH5pyUtils(unittest.TestCase):
@subtests
@unittest.skipIf(not h5py_utils.HAS_SWMR, "SWMR not supported")
diff --git a/debian/patches/0006-Tests-if-openCL-can-be-used.patch b/debian/patches/0006-Tests-if-openCL-can-be-used.patch
index 23bbcc6..c332d19 100644
--- a/debian/patches/0006-Tests-if-openCL-can-be-used.patch
+++ b/debian/patches/0006-Tests-if-openCL-can-be-used.patch
@@ -3,13 +3,13 @@ Date: Fri, 5 Jul 2019 16:52:20 +0200
Subject: Tests if openCL can be used
---
- silx/opencl/common.py | 2 ++
+ src/silx/opencl/common.py | 2 ++
1 file changed, 2 insertions(+)
-diff --git a/silx/opencl/common.py b/silx/opencl/common.py
-index b66b7b7..da966f6 100644
---- a/silx/opencl/common.py
-+++ b/silx/opencl/common.py
+diff --git a/src/silx/opencl/common.py b/src/silx/opencl/common.py
+index 60849d6..888b1da 100644
+--- a/src/silx/opencl/common.py
++++ b/src/silx/opencl/common.py
@@ -74,6 +74,8 @@ if pyopencl is None:
WRITE_ONLY = 1
READ_ONLY = 1