summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch24
-rw-r--r--debian/patches/series1
2 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch b/debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch
new file mode 100644
index 0000000..bcc32ad
--- /dev/null
+++ b/debian/patches/0004-fix-FTBFS-with-numpy-0.16.patch
@@ -0,0 +1,24 @@
+From: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?=
+ <picca@synchrotron-soleil.fr>
+Date: Thu, 21 Feb 2019 11:04:02 +0100
+Subject: fix FTBFS with numpy 0.16
+
+---
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 40b2e8e..9f6ae13 100644
+--- a/setup.py
++++ b/setup.py
+@@ -614,8 +614,8 @@ class BuildExt(build_ext):
+ extern = 'extern "C" ' if ext.language == 'c++' else ''
+ return_type = 'void' if sys.version_info[0] <= 2 else 'PyObject*'
+
+- ext.extra_compile_args.append(
+- '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
++ # ext.extra_compile_args.append(
++ # '''-fvisibility=hidden -D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))
+
+ def is_debug_interpreter(self):
+ """
diff --git a/debian/patches/series b/debian/patches/series
index 168097d..57660df 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0002-use-the-system-mathjax-privacy-breach.patch
0003-fix-unit-test.patch
0003-do-not-modify-PYTHONPATH-from-setup.py.patch
+0004-fix-FTBFS-with-numpy-0.16.patch