summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 0 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index b8759f5..58893e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,5 @@
#!/usr/bin/make -f
-# avoir bbuild FTBFS
-# export HOME=$(CURDIR)/debian/tmp-home
-# export XDG_RUNTIME_DIR=$(HOME)/runtime
-# export POCL_CACHE_DIR=$(HOME)/.cache/
-
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
export PYBUILD_NAME=silx
@@ -41,7 +36,6 @@ execute_after_dh_auto_build-indep:
# build the documentation
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
- # mkdir -p -m 700 $(XDG_RUNTIME_DIR)
pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
endif
@@ -62,7 +56,6 @@ execute_before_dh_install:
# GPU=False to disable the use of a GPU with OpenCL test
# WITH_GL_TEST=False to disable tests using OpenGL
override_dh_auto_test:
- # mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False WITH_QT_TEST=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
execute_after_dh_installdocs: