summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d086f63..19abca1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,8 @@ export PYBUILD_NAME=silx
export SPECFILE_USE_GNU_SOURCE=1
export SILX_FULL_INSTALL_REQUIRES=1
+DOPACKAGES=$(shell dh_listpackages)
+
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
# Make does not offer a recursive wildcard function, so here's one:
@@ -24,7 +26,8 @@ ALL_PYX := $(call rwildcard,silx/,*.pyx)
PY3VER := $(shell py3versions -dv)
%:
- dh $@ --with python3,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python3 $(DH_ADDONS) --buildsystem=pybuild
+build binary %-indep: DH_ADDONS=--with=sphinxdoc
override_dh_clean:
dh_clean