summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 9d8b103..1f3c86d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,9 @@ rwildcard=$(wildcard $1$2) $(foreach d,$(wildcard $1*),$(call rwildcard,$d/,$2))
ALL_PYX := $(call rwildcard,silx/,*.pyx)
#NOTA: No space before *
+# get the default python3 interpreter version
+PY3VER := $(shell py3versions -dv)
+
%:
dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
@@ -65,7 +68,7 @@ override_dh_installman:
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- pybuild --build -s custom -p 3.6 --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
+ pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
dh_installdocs "doc/build/html" -p python-silx-doc
dh_sphinxdoc -O--buildsystem=pybuild
endif