summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog16
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules6
3 files changed, 15 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index bc1d246..2ce88f8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,19 +1,23 @@
silx (0.7.0+dfsg-1) UNRELEASED; urgency=medium
- * check the pgp signature
- * remove al the thir_party code
* New upstream version 0.7.0+dfsg
* Bumped Strandards-Versions to 4.1.3 (nothing to do)
* d/control
- Build-Depends
- + Added python[3]-nbsphinx
+ + Added python[3]-nbsphinx, python-concurrent.futures
+ * d/copyright
+ remove the third_party _local files.
* d/patches
+ 0003-do-not-modify-PYTHONPATH-from-setup.py.patch (added)
- 0005-slocale.h-is-removed-in-GLIBC-2.26.patch (obsolete)
- 0006-prefer-pyqt5-over-pyside.patch (obsolete)
- * add the futures package for python2
- * removed jessie backports code
- * rework rules in order to reduce the build time
+ * d/rules
+ - removed the jessie backports specific code
+ - compile extensions only once per interpreter.
+ - unactive for now the build time tests.
+ - build the doc only with python3.
+ * d/watch
+ - check the pgp signature
-- Picca Frédéric-Emmanuel <picca@debian.org> Sun, 04 Mar 2018 16:37:41 +0100
diff --git a/debian/control b/debian/control
index 3b6f5f1..30f19b2 100644
--- a/debian/control
+++ b/debian/control
@@ -28,7 +28,7 @@ Build-Depends: cython (>= 0.23.2),
python-mako,
python-matplotlib,
python-matplotlib-dbg,
- python-nbsphinx,
+ python-nbsphinx <!nodoc>,
python-numpy,
python-numpy-dbg,
python-opengl,
@@ -56,7 +56,7 @@ Build-Depends: cython (>= 0.23.2),
python3-mako,
python3-matplotlib,
python3-matplotlib-dbg,
- python3-nbsphinx,
+ python3-nbsphinx <!nodoc>,
python3-numpy,
python3-numpy-dbg,
python3-opengl,
diff --git a/debian/rules b/debian/rules
index 150311a..de73751 100755
--- a/debian/rules
+++ b/debian/rules
@@ -52,8 +52,8 @@ override_dh_install:
# UNACTIVATED UNTIL dh_python from UNSTABLE IS FIXED
# https://lists.debian.org/debian-python/2017/08/msg00095.html
override_dh_auto_test:
- mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
+# mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
+# dh_auto_test -- -s custom --test-args="env PYTHONPATH={build_dir} GPU=False SILX_OPENCL=False SILX_TEST_LAW_MEM=True xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} run_tests.py -vv --installed"
override_dh_installman:
dh_installman -p silx build/man/*.1
@@ -61,7 +61,7 @@ override_dh_installman:
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
- dh_auto_build -- -s custom --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
+ dh_auto_build -- -s custom -p 3 --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' {interpreter} -m sphinx -N -bhtml source build/html"
dh_installdocs "doc/build/html" -p python-silx-doc
dh_sphinxdoc -O--buildsystem=pybuild
endif