summaryrefslogtreecommitdiff
path: root/package/debian10/rules
diff options
context:
space:
mode:
Diffstat (limited to 'package/debian10/rules')
-rwxr-xr-xpackage/debian10/rules5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/debian10/rules b/package/debian10/rules
index b75711c..e56f801 100755
--- a/package/debian10/rules
+++ b/package/debian10/rules
@@ -24,7 +24,7 @@ ALL_PYX := $(call rwildcard,silx/,*.pyx)
PY3VER := $(shell py3versions -dv)
%:
- dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_clean:
dh_clean
@@ -42,7 +42,6 @@ override_dh_auto_build:
dh_auto_build -- -s custom --build-args="env PYTHONPATH={build_dir} {interpreter} setup.py build_man"
override_dh_install:
- dh_numpy
dh_numpy3
# install scripts into silx
@@ -80,6 +79,6 @@ ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
#mkdir -p $(POCL_CACHE_DIR) # create POCL cachedir in order to avoid an FTBFS in sbuild
mkdir -p -m 700 $(XDG_RUNTIME_DIR)
pybuild --build -s custom -p $(PY3VER) --build-args="cd doc && env PYTHONPATH={build_dir} http_proxy='127.0.0.1:9' xvfb-run -a --server-args=\"-screen 0 1024x768x24\" {interpreter} -m sphinx -N -bhtml source build/html"
- dh_installdocs "doc/build/html" -p python-silx-doc
+ dh_installdocs "doc/build/html" -p python-silx-doc --doc-main-package=python3-silx
dh_sphinxdoc -O--buildsystem=pybuild
endif