summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c80dee7..9e3b1b0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,6 +2,12 @@
requires = [
"wheel",
"setuptools",
- "numpy>=1.12",
- "Cython>=0.21.1"
+ "oldest-supported-numpy",
+ "Cython>=0.29.31"
]
+build-backend = "setuptools.build_meta"
+
+[tool.black]
+required-version = 23
+target-version = ["py37", "py38", "py39", "py310", "py311", "py312"]
+safe = true