summaryrefslogtreecommitdiff
path: root/requirements.txt
diff options
context:
space:
mode:
Diffstat (limited to 'requirements.txt')
-rw-r--r--requirements.txt34
1 files changed, 18 insertions, 16 deletions
diff --git a/requirements.txt b/requirements.txt
index 90dc020..a69d1ea 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -3,25 +3,27 @@
--trusted-host www.silx.org
--find-links http://www.silx.org/pub/wheelhouse/
---only-binary numpy,h5py,scipy,PyQt4,PyQt5
+--only-binary numpy,h5py,scipy,PyQt5,PySide6,PyQt6
-numpy >= 1.8
-fabio >= 0.7
+# Required dependencies
+# From pyproject.toml
+wheel
+setuptools
+numpy >=1.12,<2
+Cython >= 0.21.1
+# From setup.py install_requires
+packaging
h5py
-scipy # For silx.math.fit demo, silx.image.sift demo, silx.image.sift.test
-pyopencl; platform_machine in "i386, x86_64" # For silx.opencl
+fabio >= 0.9
+
+# Extra dependencies (from setup.py extra_requires 'full' target)
+pyopencl; platform_machine in "i386, x86_64, AMD64" # For silx.opencl
Mako # For pyopencl reduction
qtconsole # For silx.gui.console
-matplotlib >= 1.2.0 # For silx.gui.plot
+matplotlib >= 3.1.0 # For silx.gui.plot
PyOpenGL # For silx.gui.plot3d
-Pillow # For silx.opencl.image.test
python-dateutil # For silx.gui.plot
-
-# PyQt5, PySide2 or PyQt4 # For silx.gui
-# Try to install a Qt binding from a wheel
-# This is no available for all configurations
-
-# Require PyQt when wheel is available
-PyQt5; python_version >= '3.5'
-PyQt4; sys_platform == 'win32' and python_version == '2.7' # From silx.org
-PyQt4; sys_platform == 'darwin' and python_version == '2.7' # From silx.org
+scipy # For silx.math.fit demo, silx.image.sift demo, silx.image.sift.test
+Pillow # For silx.opencl.image.test
+pint # For silx.io.dictdump
+PyQt5 # PySide6, PyQt6>=6.3 # For silx.gui