summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 48458e2..771374c 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@
# coding: utf8
# /*##########################################################################
#
-# Copyright (c) 2015-2020 European Synchrotron Radiation Facility
+# Copyright (c) 2015-2021 European Synchrotron Radiation Facility
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -469,7 +469,7 @@ def configuration(parent_package='', top_path=None):
except ImportError:
raise ImportError(
"To install this package, you must install numpy first\n"
- "(See https://pypi.python.org/pypi/numpy)")
+ "(See https://pypi.org/project/numpy)")
config = Configuration(None, parent_package, top_path)
config.set_options(
ignore_setup_xxx_py=True,
@@ -624,7 +624,7 @@ class BuildExt(build_ext):
ext.extra_compile_args.append('-fvisibility=hidden')
import numpy
- numpy_version = [int(i) for i in numpy.version.short_version.split(".", 2)[:2]]
+ numpy_version = [int(i) for i in numpy.version.full_version.split(".", 2)[:2]]
if numpy_version < [1, 16]:
ext.extra_compile_args.append(
'''-D'PyMODINIT_FUNC=%s__attribute__((visibility("default"))) %s ' ''' % (extern, return_type))