summaryrefslogtreecommitdiff
path: root/silx/math/medianfilter/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'silx/math/medianfilter/setup.py')
-rw-r--r--silx/math/medianfilter/setup.py59
1 files changed, 59 insertions, 0 deletions
diff --git a/silx/math/medianfilter/setup.py b/silx/math/medianfilter/setup.py
new file mode 100644
index 0000000..d228357
--- /dev/null
+++ b/silx/math/medianfilter/setup.py
@@ -0,0 +1,59 @@
+# coding: utf-8
+# /*##########################################################################
+# Copyright (C) 2016-2017 European Synchrotron Radiation Facility
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+#
+# ############################################################################*/
+
+__authors__ = ["D. Naudet"]
+__license__ = "MIT"
+__date__ = "02/05/2017"
+
+
+import numpy
+
+from numpy.distutils.misc_util import Configuration
+
+
+def configuration(parent_package='', top_path=None):
+ config = Configuration('medianfilter', parent_package, top_path)
+ config.add_subpackage('test')
+
+ # =====================================
+ # median filter
+ # =====================================
+ medfilt_src = ['medianfilter.pyx']
+ medfilt_inc = ['include', numpy.get_include()]
+ extra_link_args = ['-fopenmp']
+ extra_compile_args = ['-fopenmp']
+ config.add_extension('medianfilter',
+ sources=medfilt_src,
+ include_dirs=[medfilt_inc],
+ language='c++',
+ extra_link_args=extra_link_args,
+ extra_compile_args=extra_compile_args)
+
+ return config
+
+
+if __name__ == "__main__":
+ from numpy.distutils.core import setup
+
+ setup(configuration=configuration) \ No newline at end of file