summaryrefslogtreecommitdiff
path: root/silx/math/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'silx/math/setup.py')
-rw-r--r--silx/math/setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/silx/math/setup.py b/silx/math/setup.py
index ae0a82f..8cc15e6 100644
--- a/silx/math/setup.py
+++ b/silx/math/setup.py
@@ -1,6 +1,6 @@
# coding: utf-8
# /*##########################################################################
-# Copyright (C) 2016-2018 European Synchrotron Radiation Facility
+# Copyright (C) 2016-2019 European Synchrotron Radiation Facility
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -83,6 +83,13 @@ def configuration(parent_package='', top_path=None):
extra_link_args=['-fopenmp'],
extra_compile_args=['-fopenmp'])
+ config.add_extension('interpolate',
+ sources=["interpolate.pyx"],
+ language='c',
+ include_dirs=['include', numpy.get_include()],
+ extra_link_args=['-fopenmp'],
+ extra_compile_args=['-fopenmp'])
+
return config