summaryrefslogtreecommitdiff
path: root/silx/opencl/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'silx/opencl/setup.py')
-rw-r--r--silx/opencl/setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/silx/opencl/setup.py b/silx/opencl/setup.py
index d0181cd..a2ae244 100644
--- a/silx/opencl/setup.py
+++ b/silx/opencl/setup.py
@@ -1,6 +1,6 @@
# coding: utf-8
#
-# Copyright (C) 2016 European Synchrotron Radiation Facility
+# Copyright (C) 2016-2017 European Synchrotron Radiation Facility
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -27,14 +27,17 @@ __contact__ = "jerome.kieffer@esrf.eu"
__license__ = "MIT"
__copyright__ = "European Synchrotron Radiation Facility, Grenoble, France"
__authors__ = ["J. Kieffer"]
-__date__ = "08/09/2016"
+__date__ = "16/08/2017"
+import os.path
from numpy.distutils.misc_util import Configuration
def configuration(parent_package='', top_path=None):
config = Configuration('opencl', parent_package, top_path)
- config.add_subpackage('sift')
+ path = os.path.dirname(os.path.abspath(__file__))
+ if os.path.exists(os.path.join(path, 'sift')):
+ config.add_subpackage('sift')
config.add_subpackage('test')
return config