summaryrefslogtreecommitdiff
path: root/silx/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'silx/setup.py')
-rw-r--r--silx/setup.py54
1 files changed, 0 insertions, 54 deletions
diff --git a/silx/setup.py b/silx/setup.py
deleted file mode 100644
index 2575ebf..0000000
--- a/silx/setup.py
+++ /dev/null
@@ -1,54 +0,0 @@
-# coding: utf-8
-# /*##########################################################################
-#
-# Copyright (c) 2015-2019 European Synchrotron Radiation Facility
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-# THE SOFTWARE.
-#
-# ###########################################################################*/
-
-__authors__ = ["T. Vincent"]
-__license__ = "MIT"
-__date__ = "26/07/2018"
-
-from numpy.distutils.misc_util import Configuration
-
-
-def configuration(parent_package='', top_path=None):
- config = Configuration('silx', parent_package, top_path)
- config.add_subpackage('gui')
- config.add_subpackage('io')
- config.add_subpackage('math')
- config.add_subpackage('image')
- config.add_subpackage('opencl')
- config.add_subpackage('resources')
- config.add_subpackage('sx')
- config.add_subpackage('test')
- config.add_subpackage('third_party')
- config.add_subpackage('utils')
- config.add_subpackage('app')
- config.add_subpackage("examples", "../examples")
-
- return config
-
-
-if __name__ == "__main__":
- from numpy.distutils.core import setup
-
- setup(configuration=configuration)