summaryrefslogtreecommitdiff
path: root/silx/third_party
diff options
context:
space:
mode:
Diffstat (limited to 'silx/third_party')
-rw-r--r--silx/third_party/EdfFile.py2
-rw-r--r--silx/third_party/__init__.py7
-rw-r--r--silx/third_party/setup.py4
3 files changed, 9 insertions, 4 deletions
diff --git a/silx/third_party/EdfFile.py b/silx/third_party/EdfFile.py
index aeb9e54..b20e5bb 100644
--- a/silx/third_party/EdfFile.py
+++ b/silx/third_party/EdfFile.py
@@ -833,7 +833,7 @@ class EdfFile(object):
for i in Header.keys():
StrHeader = StrHeader + ("%s = %s ;\n" % (i, Header[i]))
self.Images[Index].Header[i] = Header[i]
- newsize = (((len(StrHeader) + 1) / HEADER_BLOCK_SIZE) + 1) * HEADER_BLOCK_SIZE - 2
+ newsize = (((len(StrHeader) + 1) // HEADER_BLOCK_SIZE) + 1) * HEADER_BLOCK_SIZE - 2
newsize = int(newsize)
StrHeader = StrHeader.ljust(newsize)
StrHeader = StrHeader + "}\n"
diff --git a/silx/third_party/__init__.py b/silx/third_party/__init__.py
index 5f31822..156563c 100644
--- a/silx/third_party/__init__.py
+++ b/silx/third_party/__init__.py
@@ -1,7 +1,7 @@
# coding: utf-8
# /*##########################################################################
#
-# Copyright (c) 2015-2016 European Synchrotron Radiation Facility
+# Copyright (c) 2015-2018 European Synchrotron Radiation Facility
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -22,6 +22,11 @@
# THE SOFTWARE.
#
# ###########################################################################*/
+"""This package embeds a few dependency of silx.
+
+This is meant for internal use.
+"""
+
__authors__ = ["Jérôme Kieffer"]
__license__ = "MIT"
diff --git a/silx/third_party/setup.py b/silx/third_party/setup.py
index 147091b..8550f53 100644
--- a/silx/third_party/setup.py
+++ b/silx/third_party/setup.py
@@ -28,7 +28,7 @@
__authors__ = ["Valentin Valls"]
__license__ = "MIT"
-__date__ = "07/11/2017"
+__date__ = "23/04/2018"
import os
from numpy.distutils.misc_util import Configuration
@@ -37,7 +37,7 @@ from numpy.distutils.misc_util import Configuration
def configuration(parent_package='', top_path=None):
config = Configuration('third_party', parent_package, top_path)
# includes _local only if it is available
- local_path = os.path.join(top_path, parent_package, "third_party", "_local")
+ local_path = os.path.join(top_path, "silx", "third_party", "_local")
if os.path.exists(local_path):
config.add_subpackage('_local')
config.add_subpackage('_local.scipy_spatial')