summaryrefslogtreecommitdiff
path: root/src/silx/image
diff options
context:
space:
mode:
Diffstat (limited to 'src/silx/image')
-rw-r--r--src/silx/image/__init__.py1
-rw-r--r--src/silx/image/_boundingbox.py1
-rw-r--r--src/silx/image/backprojection.py1
-rw-r--r--src/silx/image/bilinear.pyx1
-rw-r--r--src/silx/image/marchingsquares/__init__.py1
-rw-r--r--src/silx/image/marchingsquares/_mergeimpl.pyx1
-rw-r--r--src/silx/image/marchingsquares/_skimage.py1
-rw-r--r--src/silx/image/marchingsquares/setup.py51
-rw-r--r--src/silx/image/marchingsquares/test/__init__.py1
-rw-r--r--src/silx/image/marchingsquares/test/test_funcapi.py1
-rw-r--r--src/silx/image/marchingsquares/test/test_mergeimpl.py1
-rw-r--r--src/silx/image/medianfilter.py1
-rw-r--r--src/silx/image/phantomgenerator.py1
-rw-r--r--src/silx/image/projection.py1
-rw-r--r--src/silx/image/reconstruction.py1
-rw-r--r--src/silx/image/setup.py47
-rw-r--r--src/silx/image/shapes.pyx1
-rw-r--r--src/silx/image/sift.py1
-rw-r--r--src/silx/image/test/__init__.py1
-rw-r--r--src/silx/image/test/test_bb.py1
-rw-r--r--src/silx/image/test/test_bilinear.py1
-rw-r--r--src/silx/image/test/test_medianfilter.py1
-rw-r--r--src/silx/image/test/test_shapes.py1
-rw-r--r--src/silx/image/test/test_tomography.py1
-rw-r--r--src/silx/image/tomography.py1
-rw-r--r--src/silx/image/utils.py1
26 files changed, 0 insertions, 122 deletions
diff --git a/src/silx/image/__init__.py b/src/silx/image/__init__.py
index 12bf320..72bd116 100644
--- a/src/silx/image/__init__.py
+++ b/src/silx/image/__init__.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017-2018 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/_boundingbox.py b/src/silx/image/_boundingbox.py
index 1c086b1..c016471 100644
--- a/src/silx/image/_boundingbox.py
+++ b/src/silx/image/_boundingbox.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2018 European Synchrotron Radiation Facility
diff --git a/src/silx/image/backprojection.py b/src/silx/image/backprojection.py
index 63f99ca..b208d3e 100644
--- a/src/silx/image/backprojection.py
+++ b/src/silx/image/backprojection.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/bilinear.pyx b/src/silx/image/bilinear.pyx
index 14547f8..31ba354 100644
--- a/src/silx/image/bilinear.pyx
+++ b/src/silx/image/bilinear.pyx
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
#cython: embedsignature=True, language_level=3
## This is for optimisation
#cython: boundscheck=False, wraparound=False, cdivision=True, initializedcheck=False,
diff --git a/src/silx/image/marchingsquares/__init__.py b/src/silx/image/marchingsquares/__init__.py
index a47a7f6..1c6f15e 100644
--- a/src/silx/image/marchingsquares/__init__.py
+++ b/src/silx/image/marchingsquares/__init__.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2018 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/marchingsquares/_mergeimpl.pyx b/src/silx/image/marchingsquares/_mergeimpl.pyx
index 5a7a3b5..ce4786f 100644
--- a/src/silx/image/marchingsquares/_mergeimpl.pyx
+++ b/src/silx/image/marchingsquares/_mergeimpl.pyx
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2018-2020 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/marchingsquares/_skimage.py b/src/silx/image/marchingsquares/_skimage.py
index d49eeb0..7fa97d5 100644
--- a/src/silx/image/marchingsquares/_skimage.py
+++ b/src/silx/image/marchingsquares/_skimage.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2018 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/marchingsquares/setup.py b/src/silx/image/marchingsquares/setup.py
deleted file mode 100644
index 95998ab..0000000
--- a/src/silx/image/marchingsquares/setup.py
+++ /dev/null
@@ -1,51 +0,0 @@
-# coding: utf-8
-# /*##########################################################################
-# Copyright (C) 2016-2017 European Synchrotron Radiation Facility
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-# THE SOFTWARE.
-#
-# ############################################################################*/
-
-__authors__ = ["V. Valls"]
-__license__ = "MIT"
-__date__ = "23/04/2018"
-
-import os
-import numpy
-from numpy.distutils.misc_util import Configuration
-
-
-def configuration(parent_package='', top_path=None):
- config = Configuration('marchingsquares', parent_package, top_path)
- config.add_subpackage('test')
-
- silx_include = os.path.join(top_path, "src", "silx", "utils", "include")
- config.add_extension('_mergeimpl',
- sources=['_mergeimpl.pyx'],
- include_dirs=[numpy.get_include(), silx_include],
- language='c++',
- extra_link_args=['-fopenmp'],
- extra_compile_args=['-fopenmp'])
-
- return config
-
-
-if __name__ == "__main__":
- from numpy.distutils.core import setup
- setup(configuration=configuration)
diff --git a/src/silx/image/marchingsquares/test/__init__.py b/src/silx/image/marchingsquares/test/__init__.py
index 776bb73..0e66f61 100644
--- a/src/silx/image/marchingsquares/test/__init__.py
+++ b/src/silx/image/marchingsquares/test/__init__.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
#
# Project: silx
# https://github.com/silx-kit/silx
diff --git a/src/silx/image/marchingsquares/test/test_funcapi.py b/src/silx/image/marchingsquares/test/test_funcapi.py
index d1be584..e9d2d7d 100644
--- a/src/silx/image/marchingsquares/test/test_funcapi.py
+++ b/src/silx/image/marchingsquares/test/test_funcapi.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
#
# Project: silx
# https://github.com/silx-kit/silx
diff --git a/src/silx/image/marchingsquares/test/test_mergeimpl.py b/src/silx/image/marchingsquares/test/test_mergeimpl.py
index 07b94b5..bfa1263 100644
--- a/src/silx/image/marchingsquares/test/test_mergeimpl.py
+++ b/src/silx/image/marchingsquares/test/test_mergeimpl.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
#
# Project: silx
# https://github.com/silx-kit/silx
diff --git a/src/silx/image/medianfilter.py b/src/silx/image/medianfilter.py
index 857f73d..1938357 100644
--- a/src/silx/image/medianfilter.py
+++ b/src/silx/image/medianfilter.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017-2018 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/phantomgenerator.py b/src/silx/image/phantomgenerator.py
index 10b249b..1893368 100644
--- a/src/silx/image/phantomgenerator.py
+++ b/src/silx/image/phantomgenerator.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2016 European Synchrotron Radiation Facility
diff --git a/src/silx/image/projection.py b/src/silx/image/projection.py
index 5c76c35..0b58323 100644
--- a/src/silx/image/projection.py
+++ b/src/silx/image/projection.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/reconstruction.py b/src/silx/image/reconstruction.py
index 875b66b..2ed95c0 100644
--- a/src/silx/image/reconstruction.py
+++ b/src/silx/image/reconstruction.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/setup.py b/src/silx/image/setup.py
deleted file mode 100644
index 69d5b1b..0000000
--- a/src/silx/image/setup.py
+++ /dev/null
@@ -1,47 +0,0 @@
-# coding: utf-8
-# /*##########################################################################
-# Copyright (C) 2016-2018 European Synchrotron Radiation Facility
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-# THE SOFTWARE.
-#
-# ############################################################################*/
-
-__authors__ = ["J. Kieffer"]
-__license__ = "MIT"
-__date__ = "05/04/2018"
-
-from numpy.distutils.misc_util import Configuration
-
-
-def configuration(parent_package='', top_path=None):
- config = Configuration('image', parent_package, top_path)
- config.add_subpackage('test')
- config.add_extension('bilinear',
- sources=["bilinear.pyx"],
- language='c')
- config.add_extension('shapes',
- sources=["shapes.pyx"],
- language='c')
- config.add_subpackage('marchingsquares')
- return config
-
-
-if __name__ == "__main__":
- from numpy.distutils.core import setup
- setup(configuration=configuration)
diff --git a/src/silx/image/shapes.pyx b/src/silx/image/shapes.pyx
index 9284811..26065e1 100644
--- a/src/silx/image/shapes.pyx
+++ b/src/silx/image/shapes.pyx
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2015-2017 European Synchrotron Radiation Facility
diff --git a/src/silx/image/sift.py b/src/silx/image/sift.py
index cb1e6bd..57599cd 100644
--- a/src/silx/image/sift.py
+++ b/src/silx/image/sift.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/test/__init__.py b/src/silx/image/test/__init__.py
index 40b11a1..3ebbb32 100644
--- a/src/silx/image/test/__init__.py
+++ b/src/silx/image/test/__init__.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
#
# Project: silx
# https://github.com/silx-kit/silx
diff --git a/src/silx/image/test/test_bb.py b/src/silx/image/test/test_bb.py
index 7427273..19f5f39 100644
--- a/src/silx/image/test/test_bb.py
+++ b/src/silx/image/test/test_bb.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2016 European Synchrotron Radiation Facility
diff --git a/src/silx/image/test/test_bilinear.py b/src/silx/image/test/test_bilinear.py
index 20ceb58..d0abe64 100644
--- a/src/silx/image/test/test_bilinear.py
+++ b/src/silx/image/test/test_bilinear.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
#
# Project: silx (originally pyFAI)
# https://github.com/silx-kit/silx
diff --git a/src/silx/image/test/test_medianfilter.py b/src/silx/image/test/test_medianfilter.py
index d3386a4..3215d69 100644
--- a/src/silx/image/test/test_medianfilter.py
+++ b/src/silx/image/test/test_medianfilter.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2016-2017 European Synchrotron Radiation Facility
diff --git a/src/silx/image/test/test_shapes.py b/src/silx/image/test/test_shapes.py
index 63abc00..1adc112 100644
--- a/src/silx/image/test/test_shapes.py
+++ b/src/silx/image/test/test_shapes.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2016 European Synchrotron Radiation Facility
diff --git a/src/silx/image/test/test_tomography.py b/src/silx/image/test/test_tomography.py
index f391a72..e697cbc 100644
--- a/src/silx/image/test/test_tomography.py
+++ b/src/silx/image/test/test_tomography.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
#
# Copyright (c) 2016-2017 European Synchrotron Radiation Facility
diff --git a/src/silx/image/tomography.py b/src/silx/image/tomography.py
index 53855c1..d64afde 100644
--- a/src/silx/image/tomography.py
+++ b/src/silx/image/tomography.py
@@ -1,4 +1,3 @@
-# coding: utf-8
# /*##########################################################################
# Copyright (C) 2017 European Synchrotron Radiation Facility
#
diff --git a/src/silx/image/utils.py b/src/silx/image/utils.py
index 996d010..2659112 100644
--- a/src/silx/image/utils.py
+++ b/src/silx/image/utils.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
# /*##########################################################################
# Copyright (C) 2019 European Synchrotron Radiation Facility
#