summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@debian.org>2018-11-10 04:20:08 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-10 04:20:08 +0000
commit7f02da3c02867a0f71666c06fb136c183773800e (patch)
tree853c1ac2a17d01c6493d922c4b9e185ed40d868e /debian/rules
parent81be8f7bd65ec84d8f4235d480186c2d9667848e (diff)
Fix shebang in /usr/bin/src
Shebang provided by upstream uses python2, while best practice in Debian is to use python3, when there is choice. There is choice, since upstream deliberately maintains compatibility with both Python2 and Python3.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c257030..8d2ca7b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,9 @@ export prefix=/usr
%:
dh $@
+override_dh_auto_install:
+ dh_auto_install
+ sed -i '1s:.*:#!/usr/bin/python3:' debian/src/usr/bin/src
# Test suite requires working git installation, with user.email and
# user.name set. It is quite complicated to set up on buildd.