summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@debian.org>2018-11-27 18:21:34 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-27 19:41:26 +0000
commitdac6ac8dc84be29fdef17e80be8a5b9f3f5df992 (patch)
tree45198fee96e6fd474757be8dfc1f3283c75c08eb /debian/rules
parent97cde8bee45552a082ed37dced03de71d346225c (diff)
Rename source and binary package namedebian/1.20-1archive/debian/1.20-1
Short name 'src' is considered confusing by FTP-team (see #881896).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 6f02ed0..d6ae3c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,6 @@
#!/usr/bin/make -f
export prefix=/usr
+DESTDIR=debian/simple-revision-control
%:
dh $@
@@ -7,13 +8,14 @@ override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_auto_install:
dh_auto_install
- sed -i '1s:.*:#!/usr/bin/python3:' debian/src/usr/bin/src
+ sed -i '1s:.*:#!/usr/bin/python3:' $(DESTDIR)/usr/bin/src
# I have rather vague understanding, what `master_encoding' is,
# but using any encoding but "utf-8" looks suspicios. Actually,
# with master_encoding, provided by upstream, I get garbled
# output when trying to write commit message in non-english
# language. Hope it will not break anything else.
- sed -i '/^master_encoding/s:.*:master_encoding = "utf-8":' src
+ sed -i '/^master_encoding/s:.*:master_encoding = "utf-8":' \
+ $(DESTDIR)/usr/bin/src
# Test suite requires working git installation, with user.email and
# user.name set. It is quite complicated to set up on buildd.