summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/01-add-mplayer2-detection.patch14
-rw-r--r--debian/patches/05-add-debian-hardening-flags.patch7
3 files changed, 10 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 9d3ecdc..fa024ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-smplayer (15.9.0~ds1-1) UNRELEASED; urgency=medium
+smplayer (15.11.0~ds1-1) UNRELEASED; urgency=medium
[ Mateusz Łukasik ]
* Repackaging upstream sources to drop included zlib sources.
diff --git a/debian/patches/01-add-mplayer2-detection.patch b/debian/patches/01-add-mplayer2-detection.patch
index afb8d4a..b630d99 100644
--- a/debian/patches/01-add-mplayer2-detection.patch
+++ b/debian/patches/01-add-mplayer2-detection.patch
@@ -8,13 +8,9 @@ Debian. Since executing the mplayer program to parse its version
identification output is too heavy-weight, this change introduces a
dpkg-specific, but light-weight check.
----
- src/core.cpp | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
---- smplayer.orig/src/core.cpp
-+++ smplayer/src/core.cpp
-@@ -28,6 +28,7 @@
+--- a/src/core.cpp
++++ b/src/core.cpp
+@@ -29,6 +29,7 @@
#endif
#include <cmath>
@@ -22,8 +18,8 @@ dpkg-specific, but light-weight check.
#include "mplayerwindow.h"
#include "desktopinfo.h"
-@@ -1455,9 +1456,10 @@ void Core::startMplayer( QString file, d
- mplayer_bin = fi.absoluteFilePath();
+@@ -1597,9 +1598,10 @@ void Core::startMplayer( QString file, d
+ mplayer_bin = fi.absoluteFilePath();
}
- if (fi.baseName().toLower() == "mplayer2") {
diff --git a/debian/patches/05-add-debian-hardening-flags.patch b/debian/patches/05-add-debian-hardening-flags.patch
index d5e0124..0d271fa 100644
--- a/debian/patches/05-add-debian-hardening-flags.patch
+++ b/debian/patches/05-add-debian-hardening-flags.patch
@@ -1,11 +1,12 @@
Description: Add Debian hardening flags to qmake.
Author: Mateusz Łukasik <mati75@linuxmint.pl>
+
--- a/src/smplayer.pro
+++ b/src/smplayer.pro
-@@ -28,6 +28,11 @@ DEFINES += SHAREWIDGET
- #DEFINES += USE_FONTCONFIG_OPTIONS
- DEFINES += AUTO_SHUTDOWN_PC
+@@ -30,6 +30,11 @@ DEFINES += AUTO_SHUTDOWN_PC
+ DEFINES += CAPTURE_STREAM
+ #DEFINES += BOOKMARKS
+QMAKE_CPPFLAGS *= $(shell dpkg-buildflags --get CPPFLAGS)
+QMAKE_CFLAGS *= $(shell dpkg-buildflags --get CFLAGS)