summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-01-18 19:18:37 +0100
committerAndrew Shadura <andrewsh@debian.org>2016-01-18 19:18:37 +0100
commit1f4a55f1024fc3beda0611abbf4c5d5dafac086d (patch)
treea4e65782421bc2837edde6863333d627adfc98e5 /debian
parent5f45fc85f30a7c180044eb79a83a97dd392d10d9 (diff)
Unbreak parallel build.
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/03-parallel_mdoc.patch28
-rw-r--r--debian/patches/series1
2 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/03-parallel_mdoc.patch b/debian/patches/03-parallel_mdoc.patch
new file mode 100644
index 0000000..232a356
--- /dev/null
+++ b/debian/patches/03-parallel_mdoc.patch
@@ -0,0 +1,28 @@
+Author: Andrew Shadura <andrewsh@debian.org>
+Description: Don't run things twice.
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 8a9a498..95493d6 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -17,9 +17,6 @@ all: $(TARGETS)
+ update:
+ $(MONODOCER) $(UPDATE_ASSEMBLIES) -path:en
+
+-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
+- $(MONODOCER) $(UPDATE_ASSEMBLIES) -path:en
+-
+ $(ASSEMBLY_NAME)-docs.source:
+ @echo "Generating $@"
+ @echo "<?xml version=\"1.0\"?>" > $@
+@@ -27,7 +24,9 @@ $(ASSEMBLY_NAME)-docs.source:
+ @echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
+ @echo "</monodoc>" >> $@
+
+-$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
++$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: assemble
++
++assemble: update
+ $(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
+
+ CLEANFILES = $(TARGETS)
diff --git a/debian/patches/series b/debian/patches/series
index f62ab23..295dbff 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
01-pkgconfig_lib_path.patch
02-dllmap_fix.patch
+03-parallel_mdoc.patch