summaryrefslogtreecommitdiff
path: root/SparkleShare/Linux/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'SparkleShare/Linux/meson.build')
-rw-r--r--SparkleShare/Linux/meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/SparkleShare/Linux/meson.build b/SparkleShare/Linux/meson.build
index d3e0233..c806719 100644
--- a/SparkleShare/Linux/meson.build
+++ b/SparkleShare/Linux/meson.build
@@ -28,10 +28,18 @@ configure_file(
# .desktop and .appdata files
apps_dir = join_paths(get_option('prefix'), 'share', 'applications')
-install_data(sources: 'org.sparkleshare.SparkleShare.desktop', install_dir: apps_dir)
install_data(sources: 'org.sparkleshare.SparkleShare.Invites.desktop', install_dir: apps_dir)
install_data(sources: 'SparkleShare.Autostart.desktop', install_dir: apps_dir)
-install_data(sources: 'org.sparkleshare.SparkleShare.appdata.xml', install_dir: join_paths(get_option('prefix'), 'share', 'appdata'))
+install_data(sources: 'org.sparkleshare.SparkleShare.appdata.xml', install_dir: join_paths(get_option('prefix'), 'share', 'metainfo'))
+
+if get_option('nightly')
+ install_data(sources: 'org.sparkleshare.SparkleShare.Nightly.desktop',
+ install_dir: apps_dir,
+ rename: 'org.sparkleshare.SparkleShare.desktop')
+else
+ install_data(sources: 'org.sparkleshare.SparkleShare.desktop',
+ install_dir: apps_dir)
+endif
# Build SparkleShare