summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-11-28 19:44:42 +0100
committerRuben Undheim <ruben.undheim@gmail.com>2018-11-28 19:44:42 +0100
commiteabe7191f194bfef16cb66d5de229ec2a9ed3783 (patch)
treef52c2b4995f3727212fde33a711ac8ce780a8cae
parente77aaf69dd86975ab5559b7eb4702346c59c9f59 (diff)
Added the '-a' option to -arch invocations
-rwxr-xr-xdebian/rules12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 25ddcb5..e839ecf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,7 +25,7 @@ arch = $(shell dpkg-architecture -qDEB_BUILD_ARCH)
override_dh_auto_configure-indep:
override_dh_auto_configure-arch:
- dh_auto_configure -- -DRPATH=1 -DCUSTOM_RPATH=/usr/lib/srslte -DENABLE_SSE=0 -DENABLE_AVX=0 -DENABLE_AVX2=0 -DENABLE_FMA=0 -DENABLE_AVX512=0 -DENABLE_NEON=0 -DDISABLE_SIMD=1
+ dh_auto_configure -a -- -DRPATH=1 -DCUSTOM_RPATH=/usr/lib/srslte -DENABLE_SSE=0 -DENABLE_AVX=0 -DENABLE_AVX2=0 -DENABLE_FMA=0 -DENABLE_AVX512=0 -DENABLE_NEON=0 -DDISABLE_SIMD=1
if [ "${arch}" = "amd64" ] || \
[ "${arch}" = "i386" ] ; then \
mkdir -p obj_avx && cd obj_avx && cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_INSTALL_LOCALSTATEDIR=/var -DCMAKE_EXPORT_NO_PACKAGE_REGISTRY=ON -DCMAKE_FIND_PACKAGE_NO_PACKAGE_REGISTRY=ON -DCMAKE_INSTALL_RUNSTATEDIR=/run "-GUnix Makefiles" -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_INSTALL_LIBDIR=lib/$(multiarch) -DRPATH=1 -DCUSTOM_RPATH=/usr/lib/srslte/avx -DENABLE_AVX512=0 -DENABLE_FMA=0 -DENABLE_AVX2=0 -DDISABLE_SIMD=1 .. ; cd .. ; \
@@ -43,7 +43,7 @@ override_dh_installman-indep:
override_dh_installman-arch:
cd debian/man ; CHANGELOG_DATE="$(CHANGELOG_DATE)" ./genmanpages.sh
- dh_installman
+ dh_installman -a
override_dh_auto_clean:
dh_auto_clean
@@ -61,7 +61,7 @@ override_dh_auto_clean:
override_dh_auto_build-indep:
override_dh_auto_build-arch:
- dh_auto_build
+ dh_auto_build -a
if [ "${arch}" = "amd64" ] || \
[ "${arch}" = "i386" ] ; then \
cd obj_avx && make ; cd .. ; \
@@ -77,7 +77,7 @@ override_dh_auto_build-arch:
override_dh_auto_install-indep:
override_dh_auto_install-arch:
- dh_auto_install
+ dh_auto_install -a
if [ "${arch}" = "amd64" ] || \
[ "${arch}" = "i386" ] ; then \
cd obj_avx && mkdir -p ../debian/tmp_avx && make DESTDIR=../debian/tmp_avx install ; cd .. ; \
@@ -90,7 +90,7 @@ override_dh_auto_install-arch:
#fi
override_dh_install-arch:
- dh_install
+ dh_install -a
if [ "${arch}" = "amd64" ] || \
[ "${arch}" = "i386" ] ; then \
mkdir -p debian/srslte-core/usr/lib/srslte/avx ; \
@@ -132,7 +132,7 @@ override_dh_auto_test-indep:
# - AVX extensions (without AVX2)
# - SSE4.2 extensions (without AVX2 and AVX)
override_dh_auto_test-arch:
- dh_auto_test
+ dh_auto_test -a
#if [ "${arch}" = "amd64" ] || \
# [ "${arch}" = "i386" ] ; then \
# cd obj_avx && make test ; cd .. ; \