summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-10-06 22:04:43 +0200
committerAndrew Shadura <andrewsh@debian.org>2016-02-15 12:51:19 +0300
commitc9a0a17a54bfec1ea33c4d67c59bd114105efd1c (patch)
tree538d8ea22c8d11633d2e1f2f9a87400a2f2817a4
parent9de12366580cd1fe03b74bdda97541ead108bdd6 (diff)
Imported Debian patch 0.4-2
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--debian/docs1
-rw-r--r--debian/patches/i2c-linuxonly.patch28
-rw-r--r--debian/patches/series1
5 files changed, 38 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 73fdd97..8c35663 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+stm32flash (0.4-2) unstable; urgency=medium
+
+ * Fix build on Hurd and kFreeBSD.
+
+ -- Andrew Shadura <andrewsh@debian.org> Mon, 06 Oct 2014 22:04:43 +0200
+
stm32flash (0.4-1) unstable; urgency=medium
* New upstream release (Closes: #763972).
diff --git a/debian/control b/debian/control
index 0fc2c53..b961d26 100644
--- a/debian/control
+++ b/debian/control
@@ -24,3 +24,5 @@ Description: STM32 chip flashing utility using a serial bootloader
* start execution at specified address
* software reset the device when finished if -g not specified
* resume already initialized connection (for when reset fails)
+ * GPIO signalling
+ * I²C support
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..af8d9e6
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+AUTHORS HOWTO I2C.txt protocol.txt
diff --git a/debian/patches/i2c-linuxonly.patch b/debian/patches/i2c-linuxonly.patch
new file mode 100644
index 0000000..bb25351
--- /dev/null
+++ b/debian/patches/i2c-linuxonly.patch
@@ -0,0 +1,28 @@
+From ba7602d84be9b5f45c257c7abccc78e8257eeda5 Mon Sep 17 00:00:00 2001
+From: Tormod Volden <debian.tormod@gmail.com>
+Date: Mon, 6 Oct 2014 21:41:45 +0200
+Subject: [PATCH] Only enable i2c on Linux (including Android)
+
+Fixes failed build on Debian GNU/Hurd and Debian GNU/kFreeBSD.
+
+Signed-off-by: Tormod Volden <debian.tormod@gmail.com>
+---
+ i2c.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/i2c.c b/i2c.c
+index 9079e01..10e6bb1 100644
+--- a/i2c.c
++++ b/i2c.c
+@@ -32,7 +32,7 @@
+ #include "port.h"
+
+
+-#if defined(__WIN32__) || defined(__CYGWIN__) || defined(__APPLE__)
++#if !defined(__linux__)
+
+ static port_err_t i2c_open(struct port_interface *port,
+ struct port_options *ops)
+--
+1.7.1
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..dc59097
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+i2c-linuxonly.patch