summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lemoine <speedblue@debian.org>2019-07-25 18:38:38 +0300
committerPeter Pentchev <roam@debian.org>2019-07-25 18:38:38 +0300
commit2181877f9e406de5389daa0ed492192374f78eed (patch)
tree19ad43e97013498825830b51615e42f1539f955e
parentf1952b490580d0b38efeee7900d16c2b6220a46f (diff)
Change references to the binary from stunnel to stunnel4
Forwarded: not-needed Last-Update: 2018-12-06 Gbp-Pq: Name 02-rename-binary.patch
-rw-r--r--doc/Makefile.am4
-rw-r--r--doc/stunnel.pl.8.in4
-rwxr-xr-xsrc/stunnel3.in2
-rwxr-xr-xtools/script.sh2
-rw-r--r--tools/stunnel.init.in14
5 files changed, 13 insertions, 13 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index fbaa599..8a70a90 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -16,11 +16,11 @@ SUFFIXES = .pod.in .8.in .html.in
.pod.in.8.in:
pod2man -u -n stunnel -s 8 -r $(VERSION) \
- -c "stunnel TLS Proxy" -d `date +%Y.%m.%d` $< $@
+ -c "stunnel4 TLS Proxy" -d `date +%Y.%m.%d` $< $@
.pod.in.html.in:
pod2html --index --backlink --header \
- --title "stunnel TLS Proxy" --infile=$< --outfile=$@
+ --title "stunnel4 TLS Proxy" --infile=$< --outfile=$@
rm -f pod2htmd.tmp pod2htmi.tmp
edit = sed \
diff --git a/doc/stunnel.pl.8.in b/doc/stunnel.pl.8.in
index e12be63..83ce83a 100644
--- a/doc/stunnel.pl.8.in
+++ b/doc/stunnel.pl.8.in
@@ -70,8 +70,8 @@
.rr rF
.\" ========================================================================
.\"
-.IX Title "stunnel 8"
-.TH stunnel 8 "2019.06.10" "5.55" "stunnel TLS Proxy"
+.IX Title "stunnel4 8"
+.TH stunnel 8 "2019.06.10" "5.55" "stunnel4 TLS Proxy"
.\" For nroff, turn off justification. Always turn off hyphenation; it makes
.\" way too many mistakes in technical documents.
.if n .ad l
diff --git a/src/stunnel3.in b/src/stunnel3.in
index b83d7ae..4252992 100755
--- a/src/stunnel3.in
+++ b/src/stunnel3.in
@@ -22,7 +22,7 @@ use POSIX;
use Getopt::Std;
# Configuration - path to stunnel (version >=4.05)
-$stunnel_bin='@bindir@/stunnel';
+$stunnel_bin='@bindir@/stunnel4';
# stunnel3 script body begins here
($read_fd, $write_fd)=POSIX::pipe();
diff --git a/tools/script.sh b/tools/script.sh
index d362c23..0fed870 100755
--- a/tools/script.sh
+++ b/tools/script.sh
@@ -2,7 +2,7 @@
REMOTE_HOST="www.mirt.net:443"
echo "client script connecting $REMOTE_HOST"
-/usr/local/bin/stunnel -fd 10 \
+/usr/bin/stunnel4 -fd 10 \
11<&0 <<EOT 10<&0 0<&11 11<&-
client=yes
connect=$REMOTE_HOST
diff --git a/tools/stunnel.init.in b/tools/stunnel.init.in
index 0fd2b92..2883153 100644
--- a/tools/stunnel.init.in
+++ b/tools/stunnel.init.in
@@ -1,6 +1,6 @@
#! /bin/sh -e
### BEGIN INIT INFO
-# Provides: stunnel
+# Provides: stunnel4
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Should-Start: $syslog
@@ -21,8 +21,8 @@
. /lib/lsb/init-functions
-DEFAULTPIDFILE="/var/run/stunnel.pid"
-DAEMON=@bindir@/stunnel
+DEFAULTPIDFILE="/var/run/stunnel4.pid"
+DAEMON=@bindir@/stunnel4
NAME=stunnel
DESC="TLS tunnels"
OPTIONS=""
@@ -48,9 +48,9 @@ get_pidfile() {
startdaemons() {
local res file args pidfile warn status
- if ! [ -d /var/run/stunnel ]; then
- rm -rf /var/run/stunnel
- install -d -o stunnel -g stunnel /var/run/stunnel
+ if ! [ -d /var/run/stunnel4 ]; then
+ rm -rf /var/run/stunnel4
+ install -d -o stunnel4 -g stunnel4 /var/run/stunnel4
fi
if [ -n "$RLIMITS" ]; then
ulimit $RLIMITS
@@ -181,7 +181,7 @@ if [ "x$OPTIONS" != "x" ]; then
OPTIONS="-- $OPTIONS"
fi
-[ -f @sysconfdir@/default/stunnel ] && . @sysconfdir@/default/stunnel
+[ -f @sysconfdir@/default/stunnel4 ] && . @sysconfdir@/default/stunnel4
# If the user want to manage a single tunnel, the conf file's name
# is in $2. Otherwise, respect @sysconfdir@/default/stunnel4 setting.