summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2023-11-02 22:15:51 -0400
committerJames McCoy <jamessan@debian.org>2023-11-02 22:15:51 -0400
commit3869f1845a98fdf29a41ee19f44bece3da570312 (patch)
treea8adb6ebe8a111edb0a312b8e6907f2c47855874
parentf5cf49ac104207a657b59ba0d7af4e28d7590f9b (diff)
Skip dh_autoreconf, since we already call autogen.sh
Signed-off-by: James McCoy <jamessan@debian.org>
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 047dcdc..0002da5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -198,11 +198,11 @@ endef
%:
dh $@ --with python3 --with apache2 --builddirectory=BUILD
-override_dh_update_autotools_config:
- $(DONT_BE_ROOT)
- dh_update_autotools_config
+execute_after_dh_update_autotools_config:
./autogen.sh
+override_dh_autoreconf:
+
override_dh_auto_configure:
mkdir -p $(HOME)
env PYTHON=/usr/bin/$(PYTHON) RUBY=/usr/bin/$(RUBY) dh_auto_configure --builddirectory=BUILD -- $(confflags)