summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2018-08-01 20:44:36 -0400
committerJames McCoy <jamessan@debian.org>2018-10-02 21:50:35 -0400
commit10fa5ceab09d2b38b82f9b142bed4ddac8e79de5 (patch)
tree0cb5171cc6afc037c1d029ba45bf4fa96cb72273
parent735326cfc7db8d4e5e019f7defe2bcbaa0846e2c (diff)
ruby-no-strict-aliasing
It seems swig is generating _really_ bad code here, or something. Whatever it is, this line suppresses 1323 warnings, any of which might be real bugs with real consequences. Gbp-Pq: Name ruby-no-strict-aliasing
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 2aaf0de..7345a8a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -150,7 +150,7 @@ SWIG_PY_LINK = @SWIG_PY_LINK@
SWIG_PY_LIBS = @SWIG_PY_LIBS@
SWIG_PL_INCLUDES = @SWIG_PL_INCLUDES@
SWIG_RB_INCLUDES = @SWIG_RB_INCLUDES@ -I$(SWIG_SRC_DIR)/ruby/libsvn_swig_ruby
-SWIG_RB_COMPILE = @SWIG_RB_COMPILE@
+SWIG_RB_COMPILE = @SWIG_RB_COMPILE@ -fno-strict-aliasing
SWIG_RB_LINK = @SWIG_RB_LINK@
SWIG_RB_LIBS = @SWIG_RB_LIBS@
SWIG_RB_SITE_LIB_DIR = @SWIG_RB_SITE_LIB_DIR@