summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2018-10-09 06:41:37 -0400
committerJames McCoy <jamessan@debian.org>2018-10-09 06:41:37 -0400
commit636ef286975a8c6cf1c754c371183442edfaa3b9 (patch)
tree2f8b7888d7184c3b20b744dee1b09f4263487d2b
parent6722ad2448021478d0054c9af3d0bce399534fd6 (diff)
rules: Allow quiet builds when DEB_BUILD_OPTIONS=terse
Signed-off-by: James McCoy <jamessan@debian.org>
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b260aa9..b226a5a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,6 +46,10 @@ $(foreach o, $(d_b_o), \
$(foreach o, $(filter NO_%,$(d_b_o)), $(eval DEB_OPT_$(subst NO_,WITH_,$o) :=))
$(if $(DEB_OPT_PARALLEL),$(eval MAKEFLAGS += -j$(DEB_OPT_PARALLEL)))
+ifndef DEB_OPT_TERSE
+ MAKE_B += LTFLAGS="--tag=CC" LTCXXFLAGS="--tag=CXX"
+endif
+
# How to fix "#!/usr/bin/env " lines: $(call fix_shebangs_in, /your/dir)
fix_shebangs_in = \
find $1 -type f | xargs -r egrep -m1 -c '^\#! ?/' | sed -n 's/:1//p' |\