summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2018-08-01 20:44:36 -0400
committerJames McCoy <jamessan@debian.org>2018-08-04 12:27:23 -0400
commit8fee89125d677136d76a2af01f7c25b9ec3b8252 (patch)
treeab9d2b02679f7fb4ae611197555b240c47c3e86b
parent86b77d30dfa5e346f1c85cd9de441a16584db6e2 (diff)
ruby-no-strict-aliasing
It seems swig is generating _really_ bad code here, or something. Whatever it is, this line suppresses 1323 warnings, any of which might be real bugs with real consequences. Gbp-Pq: Name ruby-no-strict-aliasing
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index d960185..4342d35 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -150,7 +150,7 @@ SWIG_PY_LINK = @SWIG_PY_LINK@
SWIG_PY_LIBS = @SWIG_PY_LIBS@
SWIG_PL_INCLUDES = @SWIG_PL_INCLUDES@
SWIG_RB_INCLUDES = @SWIG_RB_INCLUDES@ -I$(SWIG_SRC_DIR)/ruby/libsvn_swig_ruby
-SWIG_RB_COMPILE = @SWIG_RB_COMPILE@
+SWIG_RB_COMPILE = @SWIG_RB_COMPILE@ -fno-strict-aliasing
SWIG_RB_LINK = @SWIG_RB_LINK@
SWIG_RB_LIBS = @SWIG_RB_LIBS@
SWIG_RB_SITE_LIB_DIR = @SWIG_RB_SITE_LIB_DIR@