summaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2019-11-16 13:05:42 -0500
committerJames McCoy <jamessan@debian.org>2019-11-16 13:05:42 -0500
commitff0dcb36b05eb662b51423774a4502bc04378f69 (patch)
tree0839f9b4a052f41206aebfed0c08b2b832621638 /CHANGES
parent569b75c031bd32d4ee16874ecdf225adac62514d (diff)
New upstream version 1.13.0
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES188
1 files changed, 188 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 0730c3f..66e5b64 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,191 @@
+# To view a revision listed as (rXXXXXXX), visit:
+# https://svn.apache.org/rXXXXXXX
+#
+# To view an issue listed as (issue #XXXX), visit:
+# https://issues.apache.org/jira/browse/SVN-XXXX
+
+Version 1.13.0
+(16 Oct 2019, from /branches/1.13.x)
+https://svn.apache.org/repos/asf/subversion/tags/1.13.0
+
+ User-visible changes:
+ - Minor new features and improvements:
+ * New 'svnadmin rev-size' command to report revision size (r1857624)
+ * In 'svn help', hide experimental commands and global options (issue #4828)
+ * Add a hint about mod_dav_svn misconfiguration (r1866738)
+ * Performance improvement for 'svn st' etc., in WC SQLite DB (r1865523)
+
+ - Client-side bugfixes:
+ * Windows: avoid delays in SSL certificate validation override (r1863018)
+ * Fix 'svn patch' setting mode 0600 on patched files with props (r1864440)
+ * Fix "svn diff --changelist ARG" broken in subdirectories (issue #4822)
+ * Fix misleading 'redirect cycle' error on a non-repository URL (r1866899)
+
+ - Server-side bugfixes:
+ * svnserve: Report some errors that we previously ignored (r1866062)
+ * Make server code more resilient to malformed paths and URLs (r1866318 et al)
+ * Make dump stream parser more resilient to malformed dump stream (r1866951)
+ * mod_dav_svn: Fix missing Last-Modified header on 'external' GET requests (r1866425)
+
+ - Client-side and server-side bugfixes:
+ * Fix excessive memory usage in some cases reading binary data (r1866950)
+ * Win32: fix svn_io_file_rename2() spinning in a retry loop (r1865518)
+
+ - Other tool improvements and bugfixes:
+ * svn_load_dirs.pl: do not show password; fix cleanup (r1863262, r1863392)
+
+ Developer-visible changes:
+ * New svn_fs_ioctl() API for FSFS stats, dump/load index, rev-size (r1857435)
+
+
+Version 1.12.2
+(24 Jul 2019, from /branches/1.12.x)
+https://svn.apache.org/repos/asf/subversion/tags/1.12.2
+
+ User-visible changes:
+ * Fix conflict resolver bug: local and incoming edits swapped. (r1863285)
+ * Fix memory lifetime problem in a libsvn_wc error code path. (r1863287)
+ * Faster Windows file existence checks, improving 'svn st' etc. (r1863289)
+
+ Developer-visible changes:
+ * Allow generating Visual Studio 2019 projects (r1863286)
+ * Fix build with APR 1.7.0. (r1860377)
+ * Fix building Subversion with Visual Studio 2005 and 2008. (r1863288)
+ * Allow svnserve's 'get-deleted-rev' API to return 'not deleted'. (r1863290)
+
+
+Version 1.12.1
+(Not released; see changes for 1.12.2.)
+
+
+Version 1.12.0
+(12 Apr 2019, from /branches/1.12.x)
+https://svn.apache.org/repos/asf/subversion/tags/1.12.0
+
+ User-visible changes:
+ - Major new features:
+
+ - Minor new features and improvements:
+ * 'move vs. move' merge conflicts can now be resolved (r1846851, r1851913)
+ * 'svn --version --verbose' shows loaded libraries on Linux (r1843774)
+ * 'svnrdump' can read/write a file instead of stdin/stdout (r1844906)
+ * 'svn list' tries to not truncate the author's name (r1847384 et al.)
+ * 'svn list' can show sizes in base-2 unit suffixes (r1847384 et al.)
+ * 'svn info' shows the size of files in the repository (r1847441 et al.)
+ * 'svn cleanup' can remove read-only directories (#4806, r1854072 et al.)
+
+ - Client-side bugfixes:
+ * Repos-to-WC copy with --parents works with absent target (r1843888)
+ * Repos-to-WC copy from foreign repo with peg/operative revs (#4785)
+
+ - Server-side bugfixes:
+ * Ignore empty group definitions in authz files (#4802, r1851687)
+
+ - Client-side and server-side bugfixes:
+
+ - Other tool improvements and bugfixes:
+ * svnauthz: warn about empty groups in authz files (#4803, r1851823)
+ * Storing passwords in plain text on disk is disabled by default (r1845377)
+
+ Developer-visible changes:
+ - General:
+ * Updated the required libtool version to 2.x (r1845716)
+ * get-deps.sh: Remove references to Googlemock and Googletest (r1849200)
+ * All C++ code is compiled in C++11 mode by default (r1849202)
+
+ - Bindings:
+ * JavaHL: Fixed potential core dump in ISVNClient.diff (r1845408)
+ * JavaHL: Let clients decode file contents from ISVNClient.blame (r1851333)
+
+
+Version 1.11.1
+(11 Jan 2019, from /branches/1.11.x)
+http://svn.apache.org/repos/asf/subversion/tags/1.11.1
+
+ User-visible changes:
+ - Minor new features and improvements:
+ * Conflict resolver support for added vs unversioned file (r1845577)
+ * Conflict resolver support for unversioned directories (r1846299)
+ * Improve help for 'svn add' and the '-N' option (r1842814 et al.)
+ * Improve display of Mac OS name in 'svn --version --verbose' (r1842334)
+
+ - Client-side bugfixes:
+ * Fix: repos-to-WC copy with --parents doesn't create dirs (#4768)
+ * Fix: foreign repo copy with peg/operative revisions (#4785)
+ * Fix: foreign repo copy of file adding mergeinfo (#4792)
+ * Fix: assertion failure using -rPREV on a working copy at r0 (#4532)
+ * Fix: tree conflict message ends a sentence with a colon (#4717)
+
+ - Server-side bugfixes:
+ * Fix CVE-2018-11803: malicious SVN clients can crash mod_dav_svn
+ * Fix: unexpected SVN_ERR_FS_NOT_DIRECTORY errors (#4791)
+ * Fix: mod_dav_svn's SVNUseUTF8 had no effect in some setups (r1844882)
+ * Fix crash in mod_http2 (#4782)
+
+ - Other tool improvements and bugfixes:
+ * svndumpfilter: Clarify error messages by including node path (r1845261)
+
+ - Bindings bugfixes:
+ * JavaHL: Fix crash in client code when using external diff (r1845408)
+
+ Developer-visible changes:
+ - General:
+ * Fix build on systems without python in $PATH (r1845555)
+ * Fix compiler warnings about indentation (r1845556 et al.)
+
+ - API changes:
+ (none)
+
+
+Version 1.11.0
+(30 Oct 2018, from /branches/1.11.x)
+http://svn.apache.org/repos/asf/subversion/tags/1.11.0
+
+ User-visible changes:
+ - Major new features:
+ * Shelving is no longer based on patch files (experimental) (issue #3625)
+ * Checkpointing (experimental) (issue #3626)
+ * Viewspec output command (experimental) (issue #4753)
+
+ - Minor new features and improvements:
+ * Improvements to tree conflict resolution (issue #4694 #4766 ...)
+ * 'patch' can now read non-pretty-printed svn:mergeinfo diffs (r1822151)
+ * Better error when http:// URL is not a Subversion repository (r1825302)
+ * Add 'schedule' and 'depth' items to 'svn info --show-item' (r1827032)
+ * Allow the client cert password to be saved (r1836762)
+
+ - Client-side bugfixes:
+ * Fix a crash in a repo:WC summary diff of a local copy (r1835218)
+ * Fix double diff headers (r1836746)
+ * Tree conflict resolver: avoid endless scan in some cases (r1839662)
+
+ - Server-side bugfixes:
+ * svnadmin dump shouldn't canonicalize svn:date (issue #4767)
+ * 'svnadmin verify --keep-going --quiet' shows an error summary (r1837790)
+ * Let 'svnadmin recover' prune the rep-cache even if disabled (r1838813)
+
+ - Client-side and server-side bugfixes:
+ * Fix pattern-matching of top level path in listing with search (r1830599)
+ * Allow commands like 'svn ci --file X' to work when X is a FIFO (r1836306)
+
+ - Other tool improvements and bugfixes:
+ * tools/client-side/bash_completion: Add '--password-from-stdin' (r1820045)
+
+ Developer-visible changes:
+ - General:
+ * new tool: tools/dist/edit-N-log-messages (r1819207)
+ * tools/dev/unix-build/Makefile.svn: various fixes
+ * Expose the diff option 'pretty_print_mergeinfo' in APIs (r1822014)
+ * In 'revert' APIs, choose whether to delete schedule-add nodes (r1822534)
+
+ - Bindings:
+ * Fix Python binding fs.FileDiff behaviour with python-future (r1823802)
+ * Fix Python unit test, fs.SubversionFSTestCase, on Windows (r1824410)
+ * Bump minimum JDK version required for JavaHL to 1.8 (r1831895)
+ * Enable building against Java 10 (r1841180 et al)
+ * Fix a potential crash in JavaHL (issue #4764)
+
+
Version 1.10.6
(24 Jul 2019, from /branches/1.10.x)
https://svn.apache.org/repos/asf/subversion/tags/1.10.6